Makeroid Companion + LeadBolt Bug

question

(Aman Kumar) #1

Makeroid Companion + LeadBolt Bug

Makeroid Companion Stops Working when I scan QR for Live test. I am Using latest version of companion app and using makeroid on http server.

First I Dragged Leadbolt Component from Monetization section then I scanned QR code for Live testing, then I pasted API key in leadbot and the Makeroid Companion stopped working. I tried the same thing many times even with a New project but got same results.

And when I remove the API key from LeadBolt Component everything works fine.

I have this simple blocking just for testing leadbot ads ->

Bug Report :-

java.lang.ClassCastException: java.lang.Boolean cannot be cast to java.lang.String
at android.app.SharedPreferencesImpl.getString(SharedPreferencesImpl.java:235)
at com.apptracker.android.track.AppTracker.E(l:293)
at com.apptracker.android.track.AppTracker.startSession(l:137)
at com.apptracker.android.track.AppTracker.startSession(l:216)
at com.apptracker.android.track.AppTracker.startSession(l:109)
at com.google.appinventor.components.runtime.LeadBolt.onInitialize(LeadBolt.java:158)
at com.google.appinventor.components.runtime.Form$3.run(Form.java:842)
at android.os.Handler.handleCallback(Handler.java:754)
at android.os.Handler.dispatchMessage(Handler.java:95)
at android.os.Looper.loop(Looper.java:163)
at android.app.ActivityThread.main(ActivityThread.java:6221)
at java.lang.reflect.Method.invoke(Native Method)
at com.android.internal.os.ZygoteInit$MethodAndArgsCaller.run(ZygoteInit.java:904)
at com.android.internal.os.ZygoteInit.main(ZygoteInit.java:794)


#3

Hello @amank3125
it looks like there is a component bug.
It looks for me not like a bug done by you.
We are looking into it.


(Akshay) #4

getting the same error. what’s the solution? @Mika


#5

Have you updated your companion app ?


(Akshay) #6

yes @Mika . Getting same error in live test as well as exporting apk to my phone.


#7

Show please blocks and apk.


(Akshay) #8

here is the block @Mika does i need to add anything?


(Akshay) #9

does this issue solved? can u help me with this @Mika ???


(Akshay) #10

I don’t think makeroid has an answer. Have u got any solution for it @amank3125 or you also stuck with it.


(Aman Kumar) #11

not yet brother…


(Andru Kol) #12

please fix this bug


(Roy) #13

i read this post and i got same issue with leadbolt always show error message “java.lang.Boolean cannot be cast to java.lang.String”


(Nathan) #14

Because a Boolean value (true, false) cannot be turned to ‘true’, ‘false’.


(Roy) #15

@Nathan5226 So what should i do ? I’m newbie :frowning:


(Nathan) #16

Wait til it’s fixed.


(Roy) #17

@Nathan5226 hmmm ok … thank you …