Mathjax expression

I am working with math expressions and I am doing fine with puravidapps App Inventor Code Snippets | Pura Vida Apps, my problem that is so simple is that the plus sing doesn´t show.
I am doing this
and I am getting this
Need help please.
Think there is a simple solution to this.

you must check the documentation of the extension.

It was the first thing I did, but there is no reason at all, all the examples that they did work fine with the plus sign (+).

Would you like to share aia?

Of course. The author is puravidaapps and I think, also some changes that jeprie did.
I download the aia file in this address

here is the aia

I think jeprie was facing the same problem see Problem Adding Slash (\) and Particular Commands In Mathematical Equation - #ThunkableClassicDiscuss - Community
You could always contact him and see if the problem was solved

1 Like

Please show us one of these working examples with “+”.
It seems to be that you can only use these “┼” or “⊕” instead of “+”, because all “+” are removed. Maybe it’s related to this:

@Taifun might have the answer.

1 Like

@bodymindpower is correct, all “+” are replaced by %20, which is a space
let me suggest to try this modification

  // urldecode function, without handling the case of spaces being encoded as +
  function urldecode(str) {
    return decodeURIComponent(str);



Since I found it interesting , I tried to modify the html file as @Taifun suggested but still no plus sign was showing. Then, while keeping the modified html

when we use web viewer component I replaced the + sign with %2B and it seems to work. I do not know if it is the proper way but you can give it a try


Thanks, I will try.
Thans for the interest.

Thanks a lot.
I will try what dora_paz has done.
I will let you know the result.

It works!!
Thanks a lot dora_paz

dora_paz gave me the solution

1 Like

just use ‘‘+’’ instead ‘’+’’ . There is no big difference

1 Like

Ah, I didn’t know there was this “Fullwidth Plus Sign”:


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.