Minimum API 28 Not Be Installed on My 6.0.1 Android Phone

Need Help
I have created an app using kodular platform with minimum targeted API level 28 and published it to Play Store . Unfortunately , I cannot install it on my 6.0.1 version android device :frowning_face::frowning_face: . Play Store shows a message " Your device not compatible " . I guess all the users having android version 8 or below see the same message . Now how can i target the 6 or below version android users so that they can install my app on their phones?

Use Codenames, Tags, and Build Numbers  |  Android Open Source Project

You would have to have a minimum SDK version 23 to target Marshmallow and higher. I recommend starting at Lollipop which is SDK version 21.

1 Like

According to Google

When you upload an APK, it needs to meet Google Play’s [target API level requirements]

  • New apps must target at least Android 9.0 (API level 28)
  • From November 1, 2019, app updates must target at least Android 9.0. Until this date, app updates must target at least Android 8.0 (API level 26).

if i create app starting at SDK version 21 ,it goes against google’s rule.
still i find many apps can be installed on my another 4 android version phone . how do the other developers do it? please

1 Like

You seem to be somewhat confused min and target are two different things

Min sdk is from android version it should work on and target is already handled by kodular



i get it now

same issue with me…can u guide me is google play allow to downgrade the API level…we mean our app on API level 28 and in 2nd update can we publish in API level 21…plz comment…Thanks in adv

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.