My app is not showing on screen after installing. Please Help

This is my app I made it in Kodular, URL_Short.apk (6.7 MB)

I had an app on Play Store (I published it in 2017 on Play Store), I decided to release an update of it. As I have been used to Makeroid (which is now @Kodular) due to it’s great features, I have left using Thunkable a year ago. I created the updated version of that app on Kodular on 30th March, 2019 from scratch (no relation from thunkable’s code, only I kept the same package name in order to update to play store) But it is not showing after install on any device I tested.

  • If I install with apk, it either warns (in some cases) “Apk not installed” or (in most cases) the app gets installed but doesn’t shows on screen, but it is installed there and visible in mobile phone’s settings > app manager section

  • And if I install it via play store,, the app is getting installed but there is no Open button (only Uninstall button) on play store after install. But it is still installed there and visible in mobile phone’s settings > app manager section

PLEASE HELP, I’m loosing my app users

Have you changed the version number and name?

I hate to kick you while you are down but why would you upload a non working .apk to the Play Store?

There is no Launch Activity and that’s why it’s not opening.
Did you try to recompile?
Did you do anything funky with any of the screens? Especially Screen1?

1 Like

Hi there…I’d like to point out a few things…
2- I suggest you go back to thunkable and update version of your existing app for Play Store for now pending your fix so as to retain users. Or deactivate your Play Store listing till you get a fix.
3- I think the pro members of this community will be able to help you more if you would humbly ask them privately. or you could just show your blocks for a more open approach.

Hope this helps

1 Like

This is the reason, so we can’t help him until we get an answer


1 Like

Hello @Ken and @seuntunde007 , I tested my app and it is working fine in live test so I exported it to my PC and uploaded it to Play Store

I exported app again and again, but still it is not showing. Everything is fine and complete on Screen 1. What can be the error then?

It’s weird if you haven’t done anything with your apk

I’ve checked your apk and this line is missing in the manifest file for your screen1

        <category android:name="android.intent.category.LAUNCHER"/>



I always test the .apk on multiple devices.

I’m not sure why the manifest isn’t being created correctly.

I would try exporting/importing the .aia and see if that helps.

Thanks @Boban for the quick reply, please help how can I correct this?

Because your app is from when it was called makeroid and It has been a little buggy since their name changed…

You have two folders

Do this first



Seriously, @Boban is a :superhero:


Really really many many many thanks you @Boban you are great.

I firstly tried normal way - exporting and re-importing (with name changed) but it doesn’t worked. Then, I cleared the authURL and re-imported again (with different name changed again) and it worked after exporting and installing my APK.
This helped [How to Fix] App not open / open button disabled after install

Thanks again @Boban :grin::grin::star_struck:

1 Like

Check this post as well as solution.

video help, but in Hindi Voice:

1 Like