[How to Fix] App not open / open button disabled after install

Sometimes when you install any app in your device and after installation, we cant open the app, and its not listed in the app menu. so to fix it follow the steps given below -

Steps

  1. Download Your AIA file and rename the file from .aia to .zip

  2. Extract the zip file

  3. Search the Screen1.scm file and open in any text editor. See the image below to understand.
    2

  4. clear the authURL section, just like the image given below.

  5. Save the file and compress all project files again in .zip file

  6. Change the .zip to .aia and import the project.

  7. Done,

now export apk and try. it should work properly. i tried this method and it works perfectly.

15 Likes

Maybe one of the developers can explain why this works?

3 Likes

yes… the developers should do something about this…

1 Like

Maybe it’s just Google flagging the URLs of AI, so when it’s noticed, it’s taken as a System Built-In Service?

I don’t think that deleting/changing the AuthURL is fixing anything. The AuthURL has no effect on an APK in any way, it only tells the builder which distro the aia was created in. I believe it’s just the re-importing of the project that’s fixing the issue. Try all of the steps again but without changing the AuthURL and see what happens.

2 Likes

I have a project with this problem but only happen when the app is downloaded from Google Play so I can’t test this theory. If someone has a project open sourced with this problem and want me to test this theory I would like to ry hehe

I don’t want to risk make this test on Playstore without be certain.

no… reimporting doesn’t do anything. i tried reimporting without deleting AuthURL, that method dont work. but if i remove the AuthURL and then import it works. so it must be something different.

3 Likes

yes it is happenjing with me as well . can anyone explain why is it happening ? do we have to edit all the aia files ?

I think I have found something which cause this type of error. when I created a duplicate project using save file as option and then after exporting the APK file from the duplicate project file, it has the same problem which is not open after install. So I edited the AIA file and re-import the file and it worked.

2 Likes

I just had this happened. Good thing someone had the same problem because I was pulling the last three hairs I have on my head trying to figure out why the app was installed but not showing.
I’ll open the aia as zip and do what the OP says, but it’s been a while since this was discovered. Is anyone going to fix this anytime soon?

2 Likes

This will happens when you copy your existing project and modify it and when build it shows that app is installed but open button is disabled.

This is because of package name. When you build a project by copying it from existing project your apps package name over writtened.

Try changing package name.

If problem persists then create a new project, copy all the contents from your existing project to new project and build it.

It will works.

For me, it’s strange… it only happens if I add a custom icon to the apk… something goes wrong… :thinking:

Yoshi

Can you share the icon here?

An icon isn’t secret. If you upload the app to google play, anyone can download the icon. Same goes for an installed apk, there are services.

Ok…

Look:

And I have to show you this, it’s different from the one from @techcvr:
This is how the .SCM file of Screen1 looks:
image

2 Likes

Can you try resizing the icon to 512x512 px?

Ok… I will try it.

1 Like

It’s probably for Google play store listing

For laucher icon may be 48x48 is sufficient

Img src: Android Icon Reference Chart | The Icon Handbook

2 Likes

Doesn’t work… it again don’t show the “Open” button.

Maybe i should try @techcvr’s method with the .SCM file? :thinking:

1 Like

Can you try so that the icon doesn’t have any alpha channel? Best method is to convert the image to jpg.