MySql Database 403 error

I am facing a problem with my new server. When I was on my previous server my all applications are working fine but recently I am facing some problems like 403 Forbidden (Access to this resource on the server is denied).

Another big problem is that I inserted Bangla language as my data in the database but it was not storing the Bangla in the database (I attached a pic of my data). But when I retrieve my data from my application it was converted automatically that’s why I was not worried about it. But now those data are not converting as before.

So, please help me to solve the problem.


When I asked my hosting provider they told me that the problem was not from their side.
They gave a screenshot of their security

that says that I continuously injecting SQL Injections :neutral_face:
But I just trying to retrieve my data.

is the problem with @Taifun PHP file?

Decode the text before sending to database and Encode it while retrieving back to app.

Check if the configurations are correct. Also, make sure your hosting provider allows remote access to database.

Re: To know what SQL Injection Vulnerability is and how to prevent, you can read this article below-

https://www.netsparker.com/blog/web-security/sql-injection-vulnerability/

1 Like

Man i also suffered from this issue upto two weak. I tried everything that can be. But not solved. The problem is in hosting server. You should change your hosting service

I found the solution of error 403. This error occurred when I try to make a query with information schema the server detects the query as an SQL injection. If I don’t use this query then everything looks good.

1 Like

Yes, friend, but do you need to identify why this is happening?

Permission ?

I tried all possible ways to avoid the error. I changed my PHP file permission to 655 and folder permission to 755 also checked htaccess file but the error still occurred. When I disable the block which contains those query then the error fix.

So, that’s what I said.
Now You need to check for other possible causes of this issue.

I also get that error, it comes out as that the service or the resources has been denied and some litespeed, I came to the conclusion that the problem is the hosting, but when I enter the app I can only enter when I use VPN connected to India or the US, but if I use it without vpn, it won’t let me enter, any solution?