Mysql language error

Please help me…
when I input a value except for English then I got this error in deephost extnsion…
How can I solve this error please help me

blocks (1)

Maybe you should ask the developer of the extension (Deephost).

I asked many times but no reply from Deephost.That’s why i post it hare…

Did you set proper charset in the HTML Head section?
Did you try to enter this command with these types of characters using PhpMyAdmin or any other similar tool?

Yes,I tried and successfully input the unicode value in PhpmyAdmin.
When i try to create a table in Bangla language in PhpMyAdmin it created successfully. But when I try from my apk then I didn’t…

meta http-equiv=“Content-Type”


Maybe you Will need to change the collation of your table/database/column to UTF-8.

1 Like

see also Q3 here App Inventor Tutorials and Examples: MySQL | Pura Vida Apps

deep host used my php script (btw. without giving attribution, i.e without respecting my license) and created an extension, which added only some overhead from my point of view… no extension needed… just use the web component as shown here App Inventor Tutorials and Examples: MySQL | Pura Vida Apps


I said “maybe” … I didn’t go to your site or the deep host … I don’t use extensions either, I use my Scripts. I was just and just …trying helping.

don’t worry… if I quote your post completely, the quote gets removed from the system… sorry about the missing “maybe”…
I think you are right and only provided a link to the same suggestion… I hope this clarifies this misunderstanding

keep it up!


It’s all right ! I just tried to help and explain myself to you. :+1:
Everything is good !


I tried but not working … :disappointed:

Try changing the table name from hindi to English… May be this extension is not able to support this formate… Just give it a try

It also shows the same problem…
When I try to insert an English Value then it inserted perfectly. But the problem when I try to insert a unicode value in my query…I also set my database collation as utf8_general_ci.

@kgnet202 Then this problem is related to your phpmyadmin server version

Ask your hosting provider to update it to latest

2nd solution

And second solution is use URL encoder to encode while uploading data and use decoder to when getting data from database
It will work fine
Just give it a try

I asked my hosting provider they said that their PHPMyAdmin server version is ok and the latest. But the problem with my SQL query and it was the SQL syntax error.

U tried using URL encoder and decoder???

No, I did not try this because I am a beginner with this platform that’s why I don’t know how to use this. If you explain it how to use those decoder then it would be better to understand me.

And I found another problem is that when I insert a space into a table name then it shows me the same error. Would you please tell me how can I create a table with a space in its name?

Ok wait i’ll send you blocks regarding this but try to do it by yourself too so that u can learn something more

Thank you brthr… :heart: :heart: :heart: :heart: :slightly_smiling_face: