None of the fontawesome 5 features either solid, regular or brands that work

Hello There,
I try to use Font Awsome 5 features in my app , but none of the font display on my lable

I use unicode format &#x and html enable

For Font Awesome 5 , I Use reference Fontawesome 5

Anybody please help


UPDATE : Form me

when I Use switch , bluetooth material icon typeface appear in design but not in companion

Thanks for Your reply,
Before I wrote this topic, I have read the topic that you suggest. but what I want to say, is that I want to try the features of the available kodular.typeface fontawesome and previously I have used the method suggested by Peter.

I just wondered whether the working method I used to design my application to change text labels to icons was wrong or right
If what I did was correct, then there is some kind of bug in the application creation on kodular.

Have u try

Or download font awesome ttf and upload to asset, then set Font Typeface Import to font awesome from asset

I Have Try, but not all off Character have been success

Its work

1 Like

have you been test on real phone?
I mean Not In companion

I still have this when Use Fontawesome 5 solid

@joko1 tested on real device android 10
Fa brand code  and 

Ok i’ll try with different device , maybe my device have an error

Sorry , My curios is, are you using embed internal kodular fonttypeface or use method from Peter that upload fonttypeface as asset?.

Yes… download font ttf and upload to asset

As I thought, you are using the ttf file upload method. what I want to say is, I tried the fonttypeface feature in kodular itself. not by using the uploaded ttf file.
What I have tried, everything comes from the kodular internal font typeface.
So my conclusion, what is offered in the kodular fonttypeface, not everything can work properly. like the title of my topic.

@sugarlesscreator anyway thanks for your time , to trace on this topic.

What I do to use font awesome in Kodular, is I find the icon in the website

Then I click the small button that is the icon


To copy the icon to the clipboard, and then paste it in the designer. It’s worked for me every time

Are you using Fontawesome or Fontawesome 5?

This is what I’mean

This is another Example of bluetooth button ʓ

That not works in Fontawesome 5 ( regular, solid or brand) but work properly with

I don’t see what’s wrong with using the normal built-in Font Awesome. if you absolutely need font awesome solid, as @sugarlesscreator said, go download the web font. Then extract the .ttf file, upload to assets, then under advanced settings on the Label, and select custom font typeface to the font awesome .ttf