Not able to login/signup in Signed apk from Play Console

My apk when downloaded from Kodular is working fine and Login/Register via Firebase too is working alright. But when I uploaded it to play console and sent for review, App got rejected showing Login Credentials error. I have already provided test login details in Play Console.
Now I downloaded Universal Signed apk of my app from Play Console and I’m not able to login or register in my App. it is continuously showing loading and I’m not getting any values in Firebase.
Kindly Help.

So , I need to upload new googleservices json file to assets and need to update app on playstore

No go to Projects Settings in Firebase console and add key

Added playstore SHA-1 Key but still not working :confused:

Ok now that you added it, try to download again the googleservices.json file and replace it with the file in your app. See if it works for you

I will try…

I just now tried to download apk from Kodular with kodular sha-1 key in firebase and that is also not working now. :neutral_face:

Added new json file in assets, Waited for sometime now is working fine.
Thankyou :slight_smile:

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.