Not able to save txt file

blocks (79)
Here in this block it saves txt file but i get error 2103 but even i checked the app permission and its allowed, but still i get the error, pls help me

What about trying /File.txt only
Also did you asked WRITE_EXTERNAL_STORAGE permission?

Can you post a screenshot.Also is this is all of your blocks?

1 Like


Dont understand YOU.

Can you post a screenshot of the error.It isn’t enogh to say that you got error 2103 only.
Also post your whole blocks and not one block only.

1 Like

Check whether the directory exist?
That maybe the problem I guess


1 min please

:unamused: WHYY

1 Like

i asked hime to make it /File.txt only to check if the problem is from the directory path.

1 Like

Also try this:



Will try it soon… Companion issues :sweat_smile:

1 Like

Does this works in companion (saving a file)

IT SHOULD because permission is granted

Yes but the file is written to /sdcard/AppInventor/data
From app inventor documentation:

The Companion writes files to /sdcard/AppInventor/data for easy debugging

So check this file

You must create this directory first:


Same. :frowning_face:

Try with compiled apk then

Yes i tried, still same error!
blocks (81)


I think it will be advisable to give a screenshot of the Blocks.

Where is slash before File2String?


1 Like

No, that should work, if you set the blocks correctly.

You can also try to use -

1 Like