Not loading after selecting Latest or New

On Chrome, if I go directly to the page loads quickly but after I click on Latest or New, I get a white screen(see pic below).
Is anyone else seeing this?

Am not experiencing this
Use another browser (Puffin browser) recommended

1 Like

Yesterday I had the same problem, I only cleaned Chrome’s cache and now it works.

1 Like

I tried clearing the cache and it didn’t help.

use puffin browser
Far better

I just tried it on Puffin and it is working however
I’m having some layout issue with it.

I cleared All Cache, Cookies and History and it’s working correctly again.

1 Like

I think there are some problems with Discourse in general and only on specific devices, on my phone I can’t see profile photos for example, even in my own community

I have even changed my browser, although I still have the same problem (I think it only affects to me this)

Mark it as solved

I already did

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.