Not showing ads in test mode

Hi! i created an app some time ago which had Admob advertising and is published on PlayStore. Now it is not showing ads and i’m trying to migrate to AdManager. As i don’t fully understand AdManager i’ve made some research and followed all the requeried steps. But i’m not able to show ads even on test mode.

My account is ready to show ads:

Ad manager:

That same value is on Project settings>Monetization.

I’ve created the app-ads.txt file on my own domain.

These are my blocks:

The Failed To Load event is raised and there’s no error message shown.

Here’s an screenshot of my Logcat:

Note: i can’t see any ads on test mode. Not on companion neither on compiled .apk

Am i doing something wrong? any help would be appreciated

NOTES: i’m doing this post as i’ve tried many things but nothing has worked for me. And yeah, i got kodular premium if that’s relevant

Ads are not working on Companion. Try exporting apk.

1 Like

Publish your app & check ads showing or not