Onesignal component not working in Fenix 1.5.2 Release

Working normally for me on Android 10 :thinking:



Works for me


For existing applications which were built on release 1.5.1, push notifications are coming.
When the same application is bundled in apk after release 1.5.2, the push notifications are not coming.

Did you check by creating a new push notification Id in a new app? If it’s working, then I’ll have to recreate the entire app one more time.

Yes in new application created after new kodular update

Not work in 1.5.2 for me to

1 Like

Just created a new app by your name, tried and it’s working


Checked with new application as well in Firebase, in Onesignal with new google services.json. No luck.
Somehow the new version is disintegrating onesignal app id from the app.
Always getting failed delivery.

1 Like



No, just after changing sdk target from 29 to 30 onesignal will show “Google Play Services Library Error” I’m sure

1 Like

Apk is created after the new update as you can also see the apk name which i set to prove

Don’t know what causing issue for you :thinking:

I have also used one signal in my app Gamers Spot (Api 30) and i don’t faced this kind of issue till now. Its quite working properly. My device’s android version is 11. If you face the same issue in my app please let me know.

Did you find a solution for this problem?

No but i didn’t face this kind of issue in my app.

I know so I ask the users who are facing the same problem if they found a solution because if they succeeded in determining the reason of this problem this may help me.


No solution till now. In fact one signal stopped working for me. I’ve created multiple new apps, no solution.
Let me know if anybody understood the root cause and come up with any solution.
This release was my last hope, but looks like dusted.


1 Like

And have you followed the instructions you just showed us

I don’t know how to change google play services version and I don’t know what is logcat so I asked for help.

I am sure that if sdk target in AndroidManifest.xml is 29, onesignal works properly. If I just changed sdk to 30 the problem appears

I want to tell you that I built a new app after new Kodular update and a new firebase app and a new onesignal apps and it doesn’t work. But when I decompiled the apk and changed sdk to 29 then tested again it worked properly.

So I am sure that there is something have to change in AndroidManifest.xml when sdk is 30 to allow the app to connect to onesignal.

Can you show me manifest permissions