PhoneCallEnded block not working


I was using MIT until I came across a bug with PhoneCallEnded block not working.
I reported it as a bug, they confirmed it is a bug and will fix it, but a fix will be available only from mid-July. Because of that, I searched for MIT alternatives and came across Kodular to find out the same function still doesn’t seem to work.
I guess Kodular is using MIT APP blocks, and only when they fix it it will be fixed here also.
Is this correct?

You should provide some informations which block have a bug.
We dont need to wait for AI fixes when we know whats wrong

1 Like

You mean this issue?


No, I mean this one.!searchin/mitappinventortest/phonecallended|sort:date/mitappinventortest/s3eV2jK0eaQ/wJ-uPIVVBQAJ

MIT has a Companion version (u) that should still work regardless regression, and that version is also not working. That’s what I found out and they confirmed to be a bug. Maybe Kodular doesn’t have that alternative version, or maybe I am not using your correct companion.

I just tried the same code in Kodular and it also didn’t work.

The issue i posted is the one that was made because of the topic you posted on the App Inventor forum.

I believe such issues was possibly what made them have an alternative version of their Companion.
I had read that post before when I was looking for a solution to this problem.
If you use MIT alternative companion (version 2.53u) you wont be able to place your app on google store, but you wont be subject to this regression. The problem is that PhoneCallEnded is not working also with this 2.53u version, and I believe that is why they acknowledged it as a bug and are fixing it.

But anyways, I forgot about that regression from Google that will probably always affect that PhoneCallEnded function and that is possibly why it also it didn’t work in Kodular.