Photo is not Cached

my first application
I tried it myself application is almost ok I have 2 problems.

1) No Cached image is retrieved.
( It was working before adding it without messing with “ListUtils” )

2) The Favbutton is not Active when the “Prevv” page is opened.
(When you come to the “prevv” page from “favpage” and “screen2”, the Favbutton is not Active, but when you make it right and left, it becomes active )

Try with Load imageAsync once

I haven’t found any blocks setup to make fav button active on screen initialization. But you have set fav label change system on PhotoView1.onPageSelect event.

1 Like

thanks for the answer.

Favbutton fixed the issue. :ok_hand:

imageAsync didn’t work.
imageloader was working,but
I started using listutil on airtable and it broke.
I restored it didn’t work
where is the problem
it works when the bottom block 72 is like block 73.
My first application, I have little knowledge and it is very difficult to solve the problems alone

It shows some error ? Post it.
Which data there is in the values ? Is an empty list ? Before your changes the list utils worked right ?

1 Like

post it:

I made 2 changes, it was working before the changes

  1. I changed screen 2 and “prevv” with different airtable
    (same number and photos,screen2 1200w pixel)

2)ListUtils broke after changing.

If you know that is the list utils the problem, check the data in input and output.

i need an alternative solution

It doesn’t work in the 1st picture.
it works in the 2nd picture.
The 2nd picture shows the data received from the db while listutils is disabled.(favorite pictures db1)

Try to save data in a variable and then use reverse block with this variable . If it works probably the reverse block doesn’t work directly with got column values . If doesn’t work probably there is a problem with reverse block or kind of data you are using .
Using a variable you can make a do it to show the error, if there is

1 Like

thanks for the help
I fixed it with a few changes. :smiley:

1 Like

So the problem was you managed image URL before get the data ?

1 Like

There is no error in the previous usage.
There was a listutils issue.
Based on what you said, I came to the conclusion that 2-3 changes.
Thank you very much :smiley:

1 Like

Check as solved in the right reply , so community know where is the solution :muscle:t2:
Have a nice day

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.