Please help to solve: Cannot read properties of undefined

The issue was reported more than 2 months ago, and still isn’t properly addressed.
Why the “importing module” cannot fix it automagically?
If some property is missed in .aia, and it is required, why it can’t be set to some default value?
(see also duplicate)

Muito grato, deu certo. conseguir compilar. Sou um pouco leigo com essa tecnologia, mas ocorreu com sucesso. Acredito que quem estiver com o mesmo problema, é possível corrigir seguindo esse procedimeto.

Translation added by Mod

Very grateful, it worked. be able to compile. I’m a bit of a layman with this technology, but it happened successfully. I believe that anyone with the same problem, it is possible to fix it following this procedure.

Welcome to community. Official language is English. This time I added translation to your post but next time please follow community’s rules

1 Like

please help me with the same error Cannot read properties of undefined (reading ‘indexOf’)
addmon.aia (7.4 KB)

Try this

addmon_1.aia (8.9 KB)

Error generating Yail for screen 5641375477399552_Screen1: : Cannot read properties of undefined (reading ‘indexOf’). Please fix and try packaging again.

Here is the aia :
uTranslate (1).aia (230.5 KB)

Please help me
Thanks is advance
happy koding

uTranslate_1.aia (230.5 KB)

Here is the guide how to solve this kind of problem by yourself (based on investigations performed in the context of similar issue).
Usually such issue happens when you try to build APK-file for a project imported from another quick-design system (like MIT App Inventor), and caused by missing properties inside (a special file inside .aia).
Here are the changes you should make in Project settings (in Makeroid):

  1. Select another Minimum SDK Level under Publishing - set it to Android 4.4 - 4.4.4 (API 19) (if it was empty) or to Android 5.0 - 5.0.2 (API 21) (you should change it at least once):

  2. Toggle Splash Screen and RTL Support under General (typically you can leave them OFF, but you should change them explicitly in Project settings at least once)

  3. Select Theme under Theming - set it to Default or you can try other values (you should change it at least once)

Try to build APK-file.
If the build succeeds, you are good to go! :slight_smile:
If not, post the original project here, and maybe someone will tune it for you.
I hope this functionality will be fixed some day in the importing module :slight_smile:

This works 100%

happy koding

error generating yail for screen kodular

I got this problem please help me

Have you check for missing project settings as shown above ?