Problem deleting text in textbox

I write a text in the textbox1 and I have a result in the textbox2. when I want to erase the text I have false which appears, I replaced it with an empty text, but afterwards there is a bug, how to thank you
blocks (1)

I didn’t get what your trying to do

I have two textboxes: I write in one and I have the answer in the other. My problem is when I want to erase the two texts, I get “false” in the first texbox and “not found” in the second textbox. I tried to replace “false” by an “empty text” it works, but after a few seconds I have the data of “firebase” which appears by itself.

in fact when I want to delete, either I have false which is normal, because the logic equals “empty text” and delete equals “empty text”, but if I put “empty text” instead of false and I delete, I have a part of my “firebase” database that appears.

Still it’s way too much confusing show your all blocks and also the UI part

blocks (1)
blocks (2)
blocks (3)
blocks (4)

So you don’t want false in write_and_read box you need it empty?

If I empty myself, after a few seconds, I have database data that appears

I noticed that the problem where my database appears, only happens when I use “on text changed”, but if I use a button, the problem does not appear. and I want to avoid using a button.

Do one thing onTextChanged when textbox is empty don’t call firebase .Get Value block

ok, but if I don’t put block, I don’t have the value (the answer)

still no answer to my basic problem which appears after a few when I erase a text.

I managed to make my app work using Taifun’s textbox extension, I no longer have to go up the database, but there is an error: java.lang.StackOverflowError: stack size 8188KB

blocks (1)