Problem with Activity Starter method resolve Activity

Hello to all,
I’m having a problem with the activiy starter. When I run an activity, the resolve activity method always returns empty to me, even if the activity is working.
I use android 11 and the problem occurs in the test phase with the companion, but also by trying the installed apk.

Until a few versions ago it worked for me, I can’t find out if it worked before 1.5.2 or before 1.5.3.

@enfandroid See this

1 Like

I know this, but in my case it always returns an empty string, even when I call an activity that works in the app.

share the blocks let me also try this

This is my code. I had to disable the check because it always returned true to me.

Try setting first Action and then Data Url

Done, but I haven’t solved it.


Thanks for sharing, I have read and it is certainly related to my problem, but I am missing something. In my case the activity works, what doesn’t work is Resolve Activity which always returns empty.

Remove above block

With the code highlighted in my image, the activity works for me, I wanted to catch a possible error, but in this way I could not do it. It is probable that the management logic is not clear to me.
Maybe I have changed something without realizing it, I have to study the logic better. Thank you all

That’s exactly same as what you read that thread.
You can’t get info about other apps but you can open them

Ok now I understand better. But is that something that has changed recently? Android 11?

This works just fine for me and on my device with Android 11


However, it seams that it work somewhat differently than on MIT AI2…

In my device this is not working. I thought it was normal, following the above, that is new Google restrictions, but now with your statement, I have doubts again.

Btw, are you using companion version 1.5.3

Yes, of course

you might want to prepare a small example project as small as possible and add it here in this thread, so others can try it on their device…



This is an example of blocking in an empty app. Is it normal for me to return an empty string? If you want I can attach aia, but it is very easy to reproduce.