Problem with audio files in AAB

help me deal with the following problem:
compiled Apk → changed manifest → created AAB. there are no errors
, then to check, I extract apks files from AAB, install them on a smartphone-everything works except for sound files (they are in asset, but they do not see them. all other files (graphics) in assets (except audio files)
permissions are given.
audio files in AAB are not compressed.
what’s wrong? how do I set the path to the sound file that is in assets?
I tried the options “//s.wav”,“file:///s.wav” - to no avail.

Before compiling your application, upload one sound file and it will work.

the audio file is located in assets. the path to it is specified in the constructor. when trying to reproduce this file, an error occurs - the file is not found

It would really help if you provided a screenshot of your relevant blocks, so we can see what you are trying to do, and where the problem may be.

To get an image of your blocks, right click in the Blocks Editor and select “Download Blocks as Image”. You might want to use an image editor to crop etc. if required. Then post it here in the community.



it is clear that the aab archive is formed not from the editor, but outside it. this asset is present there. I don’t understand why he doesn’t see the file. it is in assets.
testing_sound.aia (12.1 KB)
that is, if I create aab directly from the editor, then there are no problems, but if I create aab from the apk, then I do not see the sound file. it is the sound files that I do not see from the resources. and I can’t beat this delem in any way. I don’t understand what the problem is. I tried different options - it didn’t help. help pliz

I have the same problem I need a solution

Searching the community can help to find a solution…


after a long torment in finding a solution, I came to the following conclusion: the means of playing audio files from Kodular when manually creating AAB archives do not work at all. This is not affected by the compression of files, their extension, or permissions. The player just doesn’t work properly, sound and that’s it. the only solution that is currently possible is the use of ExoPlayer in the project. however, it doesn’t work in the Kodular constructor itself :slight_smile: For the experiment, I just use regular playback tools in the constructor, and ExoPlayer outside of it. At the same time, mp3, wav, ogg and other sound files can be played well independently.