Problems getting data into list and show with ColinTree ListView

Hi there.

I’ve been following this video here: YouTube

But the list shows nothing. The data is collected, I’ve tried to put the data in labels, and it works, so there has to be something with the block ‘When Bilde .Got Column’.

Here my blocks are:

Any tips on what I’m missing here or have done wrong?

Hello @Choofa
How many records do you have in your Airtable spreadsheet?

See the image below:

@Vaibhav Does not help changing those, I’ve tried. And it works on video-tutorial with max 100, so it should work for me as well :stuck_out_tongue:

i work with more as 100 Items in each list and i have no problemm to work with that extension what i know is there a new update because to work with more than 100 Items in a list. Some users had problems with that. But all of all it works very well for me. I think ColinTreeListFView is one of the best List Viewer.

I will have no more than 20, as this is only a to do list :stuck_out_tongue_winking_eye:

Check with the Do it option if your lists have all the data what you want

When I do that nothing happens :thinking:

You have run your companion app and than you can use the do it option

I always use ompanion when I work with app. But nothing happens when I use ‘Do it’.

if you click on a global variable which is your list or where your items are stored. And than you have to click on do it option.

I get this error on both variable inside .Get Column block

Companion can’t return value of non-global variables

Ok, but how to fix this then? Cuz this is the way it’s done in the video?

@The_Developer_2.0 How did you manage to do this, and I dont?

You can use one of these methods.

  • Use Notifier Toast or something to show the non-global variables.
  • Transfer the value to a global variable.

You can try to return your ToDoBilde variable instead of returning get values.

Sorry, I don’t understand?

Please check again I just edited it again.

But ToDoBilde is a global variable?

I don’t understand this option :thinking:


The Get Collum method does not have a value to give (In other words, the “values” varible is null)
Use the method first to get a value.

Fortsættelse følger…


Ok, I see.
Now when I try Do It on the Call Column blocks it shows me error, the list is null

But I don’t understand why? API, Base Name and Table name is correct.

There doesn’t have to be an error, The method (Get Column) Just haven’t been used and there for doesn’t have have a value yet. Just like a lottery ticket you need to scrape. You need to scrape the layer to see if you won anything :slight_smile: