Problems with Activity Starter

Because it is a “Runtime Error”, it may be device-specific. Can you please prepare a test app for us to test on our devices?


it says the Carta.pdf is not in your phone or wrong path to open pdf

Doesn’t say anything, just start opening the PDF Viewer and close before open any file. The PDF file is in the right folder. When the app is tested using the companion tool everything work perfectly. I guess the big problem is that, with the companion works and after compile doesn’t work.

that because you enter type application/pdf so your application think its pdf file and it open pdf viewer for viw the file but file was not there, so then the app says pdf not found in apps language

Sorry but this is not what is going on. How do you explain that the same app works on companion and open the .pdf file that is in the correct folder?

The real problem is the companion works to open a pdf file and when compile and installed on the phone doesn’t work. I remark “to open a pdf file” using the app on the phone already installed and not using the companion.

All this issue would be easy to solve if anyone create a simple app with a button to open a pdf file in the phone previously saved.

I am getting the same problem. Activity Starter doesn’t works to open a file with custom package name. This problem is in just kodular. Hope they will fix this issue as soon as possible :pensive:

Kodular please fix it . I m Losing My audience please

If you all are in a hurry and can’t wait for the fix then do a real package name change


1 Like

This post was flagged by the community and is temporarily hidden.

blocks (39)

this way it worked on my app

Not very helpful since we don’t know what you have in this block


1 Like

i’m pulling a pdf file straight from airtable to actvity_stater1, to open in to the mobile’s native pdf app to display my pdf file

blocks (41)

That’s from web, we are talking about file from storage

1 Like

Has he tried to put everything together? like this in one block?

file: ///mnt/sdcard/TripuraSelectedNewspaperPDFs/PAGE-1.pdf

Just realized that the thread is more than 1 year old so no point in posting here more


A post was split to a new topic: An internal error has occurred

Is this problem still not solved?

I am getting same error when opening a pdf file from storage with activity starter.

I am using custom package name and i can not change it as my app is already published on play store.

Problem is solved when using default package name.

Now i have a problem,

I have published my app on play store with custom package name.

Now i have changed it to default package name, what happens if I try to update the app with default package name?

YesI also have same problem. @KodularCreator pls help us