Quite desperate with Firebase rules. Please, help!

Dont share the video which are not in english… Already one post was hidden by the mod. Again and again sharing such videos mean there may be the chance for mute/suspending the account…

If the app works fine for what you need, stores and retrieve data without problems but the message keeps appearing, leave this block empty:
and ignore the error.
If data is not stored or retrieved, even after the id token solution, probably there is a problem with the FB rules.

Sorry to repeat this. We will not repeat this again in the near future. I will do it and publish it translated into English
After completing my studies

1 Like

The firebase rules are simple.

“rules”: {
“U”: {
“$uid”: {
“.read”: “auth.uid == $uid”,
“.write”: “auth.uid == $uid”

The app works perfectly when I freshly install it or when I delete all data and login again. It stops working of I open the app after a while like say overnight.
Its a very wierd problem.

But the problem is related to FB? Which is the error message? Maybe It has to be with the initialize screen block, but we need to know more so we can try to help.

I’ll try this once. If it doesn’t work then shall post my blocks. Thanks for your time

I also try anyway, when I install the application from 0 and the user logs in, it works perfect, the problem is when the user changes the application and an hour passes (the token expires) and when he re-enters the application I get the Firebase permission denied error. I have tried to refresh the token (which it does correctly) but the error still appears, I don’t know what else to do. it’s a firebase bug

“rules” : {
“project bucket name” : {
“.read” : true,
“.write” : true
“$user_id” : {
“.read” : true,
“.write” : true

Note: Project bucket is the main bucket and $user_id is the sub bucket under the main bucket. So if you have sub bucket with user uid under any project bucket you have to gives access to $user_id otherwise it will show permission denied. Also keep in mind that you have to create rules for every main bucket you create in the database and the sub bucket.

have you found a solution?

If the problem is solved, can you take a screenshot of your FB rules and application blocks?

I’ve been trying for months, this will help me a lot.

Thanks in advance.