Recast • Make your old extensions compatible with Kodular Fenix

This is what i am getting. I am on windows 7 with powershell 5.x

Are you sure your Windows installation is 64-bit? Recast doesn’t yet supports 32-bit Windows.

1 Like

Yes Its windows 7 ultimate SP1 64 bit

and Powershell Details

Name                           Value
----                           -----
PSVersion                      5.1.14409.1005
PSEdition                      Desktop
PSCompatibleVersions           {1.0, 2.0, 3.0, 4.0...}
BuildVersion                   10.0.14409.1005
CLRVersion                     4.0.30319.42000
WSManStackVersion              3.0
PSRemotingProtocolVersion      2.3

Can you try running Recast using Command Prompt (CMD)?

I tried same error

thread ‘main’ panicked at ‘called Option::unwrap() on a None value’, src\
note: run with RUST_BACKTRACE=1 environment variable to display a backtrace

Im getting the same error, and im on windows 10, and it is 64-bit

Can you send me the extension that you’re trying to recast?

Im trying to recast many extensions together which is in a folder

It’s cn.kevinkun.KevinkunEnhance (1).aix that causing the problem. Send it to me.

1 Like

This post was flagged by the community and is temporarily hidden.

It has space in the name


Spaces should not cause any issue. Nvm, I’ve already fixed it, waiting for the CI to publish the release on GitHub. :grin:


Recast v0.1.2


  • Fixed the issue that crashed Recast if the host terminal didn’t have ANSI support.
    Thanks @rohan4877 for reporting.

  • Fixed the issue where Recast would panic if the extension didn’t have the file.
    Thanks @Soham_Shah for reporting.


To upgrade from older version to v0.1.2, simply go through the installation steps mentioned in the first post:



This post was flagged by the community and is temporarily hidden.

This post was flagged by the community and is temporarily hidden.

If it is android x library problem it will be fixed in recast so Just recast and if it skipped then the problem is not with android x but if it is updated in recast then try and see whether it works or not

1 Like

I would imagine that we should keep this tool handy for a while in case we wind up getting some old extensions that weren’t updated to the current libraries? Also, how would we uninstall recast if needed?

work for me, but some extension showing this

how to fix ?

There is nothing to fix


To uninstall Recast, all you need to do is delete the below mentioned directory:

  • Windows: %UserProfile%/.recast
  • macOS & Linux: $HOME/.recast