Remote config cache problem

I am using remote config for fetching data while updating the data in firebase remote config the updated data is not reflected in the app while reopening the app, I have tried reducing the cache expiration time but that is also not working, If we clear the app data the changes which I have made in firebase gets reflected in the app, Does anyone have the solution for this problem because in firebase docs the default cache expiration time is 12 hrs while in the kodular it is 43Secs by default

Do you think,Really, it is due to cache problem? … well, not sure… Can you show your block in which you getting values from firebase when it is updated…


Did you tried with this block?

This is the block for firebase database, I am using firebase remote config

Oh, i got it. Did you check cache expiration value?

Yes, I have tried with different values by setting it in designer and also through the blocks

If you set the value as 1, then you can see the result immediately it will get reflect.

cache expiration time is in millisecond and I have set many different values like 10,3000,10000 etc