Runtime error : google map failed resolution of:lorg/locationtech/jts/geom/GeometryFactory

I checked out Kodular Fenix (v1.5.0) Bug Tracker before creating a new topic

Describe your issue

do you know error it, how i can fix that? component google maps

Steps to reproduce the issue

Expected Behaviour

Actual Behaviour

Show your Blocks

Android version

Android 7.0 (Nughat)

have you found the solution?

I also found the same error in my app with following components

  • Google maps
  • Navigation

I found the solution by adding Map component and hide it by setting visible to false.
I think the problem is Map and Navigation should be together.

1 Like

Thanks, I added map component and then worked fine :grin:

This solution ?

:point_down:

I didn’t see this post before during my search. So I try it by myself with the simple assumption that the components should be used together.

Also there was

where did I add the maps component? because I use google maps and the navigation is not in one line. Then, in the block section is there anything that should be added?