Rush • A new and improved way of building extensions

Try performing a forced upgrade using rush upgrade --force.

Fyi, Rush uses version 1.5.10 of the Kotlin compiler.


Its fixed now as i’ve installed kotlin compiler


I am trying to build extension. it is showing this. why?

1 Like

I have the same. No error or anything still fails. :frowning:

It seems you are on linux too. It might be an issue with linux. Hope we will get the answer soon.

I have installed

openjdk version “1.8.0_292”
OpenJDK Runtime Environment (build 1.8.0_292-8u292-b10-0ubuntu1~20.04-b10)
OpenJDK 64-Bit Server VM (build 25.292-b10, mixed mode)

Such abrupt failure of the build usually happens when Rush fails to invoke the Java compiler (javac). There could be many reasons behind this, but the two I can currently think of are:

  1. You don’t have JDK (Java Development Kit) installed, or
  2. javac is not on the system path variable; quite unusual, but may happen.

Can both of you try running javac in the terminal? If you get an error saying command/program not found, you might need to install JDK 8, or add javac to your system’s path variable.

PS: @72erdelyi, you seem to have JDK installed on your computer. It might be that javac is not your system’s path var.


Command ‘javac’ not found here

I have fixed it here. Thanks a lot

installed sudo apt install openjdk-8-jdk-headless


@Shreyash One question, is it possible to use the “helpUrl” ? If the answer is no, is it possible to add it ?

The helpUrl property has been replaced with homepage field in rush.yml. This is how you define it:

homepage: ''

I can successfully build the AIX file and import and use in Kodular. Once i try to run the application i receive the following error:
Also i cant build the APK file from Kodular because of an error in my application.

My blogs about this application is very simple and includes only dummy data:
blocks (1)

And this is the code i compiled using Rush:

I really can’t figure out what i am doing wrong…
This happens no mether what method i’m trying to execute.

Can you try hard resetting your companion? Also, make sure you are using the latest version of the companion.

What is that error?

1 Like

This is the complier error (when i try to compile the application and download APK):
ERROR: io/kodular/markocurlinoski_uie/ExtensionTester/Screen1.yail line 28: caught exception in inliner for # - java.lang.RuntimeException: no such class: io.mchurlinoski.jsonpathext.JsonPathExt

And the error I’m getting from the UI, when i try to run the application on companion is:

My bad. At first I deleted all default code and replaced it with wrong one (wrong class and pacakge name) and i tried to fix it manually and i failed. The extension is working as expected now.
BTW: This is great, i’ve been looking for this kind of tool all day and i finally found a good one.

1 Like

@Shreyash I am starting to use Rush. Will you please tell me how to set environment variables for this.
I have set JAVA_HOME with value C:\Program Files\Java\jdk1.8.0_301 in System Variables. Now what I have to set in PATH Variable and what will be the Value.
By the way thanx for this great Tutorial

That’s all that’s needed. Now go ahead and install Rush using PowerShell if you haven’t done that already.

1 Like

@Shreyash see this and error

What can be the error
And how to solve it
Thank you
@Xoma If you can help me then please help

You seem to be using a very old version of PowerShell. Try upgrading it to the latest available version.

1 Like

Ohk but will you please provide me with appropriate link with the latest version of PowerShell

I mean to say from where I can download latest version

One way is to download powershell from Microsoft store