Screen not initializing


(Nathan) #1

Steps to reproduce the issue

- Use the when Screen[int].initialized event with blocks under it, for example Hosts[int].GetDevice. Doesn’t work for companion or built APK.

Expected Behaviour

Initialize screen properly and send event to contact blocks under it.

Actual Behaviour

Some blocks used for my example seem to not work, but they work on other events such as a timer.

Show your Blocks

Screenshot%20(71)

Android version

Permissions were allowed. Android 8.0.0


(Nathan) #2

Just a short note: Even under the timer for a built APK, it still doesn’t seem to work yet on the Companion it does.


(Nathan) #3

Actually sorry this may be a false report as it may have something to do with Hosts not looping back to itself after checking if permissions were granted :sweat_smile:, I guess you have to put it under a future block which will be out Sunday.


(Carambel) #4

I have the same problem, but it can be solved with other blocks.


(Nathan) #5

Having the same problem using Hosts blocks or any block?


(Carambel) #6

The screen block “Initialize” yes, I do not load admob, but I almost do not use it so there is not so much problem.


(Carambel) #7

It was solved when updating the apk, with the latest version of Kodular.