Screen size detection and component auto height issues after Kodular Fenix 1.5C.0 update

Hi folks,

I’ve been developing an app for quite a few months now. It’s been working fine, until this week. The app is complex and large in terms of blocks and processes, but has worked perfectly. The GUI is comprises a number of vertical layouts and cards, most of which have their height set to auto.

These vertical layouts and cards should resize automatically, so that they all fit on the screen, and text size will adjust automatically to suit the size of the cards. That was all working fine until sometime around the 16th October, but now it doesn’t work, all the layouts/cards are larger in height than they used to be, and the bottom layout component clips its contents, so most of it is off the screen.

I have changed absolutely nothing in the layout of the app. I have no idea how this could have happened. I didn’t add or change any plugins, all I did was work on a few processes for data manipulation, but nothing to do with the layout or GUI of the app. I cannot understand how this has happened.

I have also loaded saved copies of the AIA from the past few weeks and every single one of them now has the same issue, but they worked absolutely fine when I saved them. This makes be suspect it may be Kodular that’s changed, not my app. Has something changed or been updated in the Kodular system in the last week or thereby that could have affected this? It looks like the companion app possibly updated a few days ago, but my issue occurs in both the companion app and apks.

Green button should look like this:

Green button text now clipping:

I am also noticing that plugin I use (called GetMetrics) to detect the screen height to show or hide a FAB button depending on the screen size is now not working correctly. The FAB is displaying on larger screens when it should be hidden. I thought this was a separate issue at first, but I am now wondering if it could be related. Again, that plugin hasn’t been changed or updated. I worked two days ago and now it’s not.

I haven’t changed any of the layout of the app and I’ve not added or changed any other plugins/extensions. All I did was work on it a few days ago, did nothing for a couple of days and now I’m back working on it again, I’ve got all of these issues. And all the issues seem to relate to the height of the screen/app being incorrect.

Do any Kodular gurus know if something has changed in the system and could be the reason for this? I have spent hours manually comparing my blocks in the current version with the ones used to generate the last APK that work’s correctly and they are identical, so I just cannot see how it could be something I have done.

I would also mention that around the same time, I became no longer able to save the AIA by clicking ‘save’ and had to revert to ‘save as…’. to save a full new copy of the project Until then, the save function worked flawlessly. It also seems to have occurred around the same time generating APKs became exceptionally slow, which I see other people have complained about in this forum.

Many thanks indeed! :slight_smile:

Looking into this more, all of these issues occurred after kodular was updated to Version 1.5C.0. I can’t see form the brief change notes what would cause this though. Is there anyone from Kodular actually active on these forums these days?

Unfortunately they are in deep sleep since more than 2 years… occasionally @Diego or @pavi2410 wakes up for a minute…



Thanks, Taifun. I appreciate that.

I don’t suppose you’ve got any ideas how I might be able to address the issues I’ve got? Given I haven’t changed anything in my app, only Kodular has changed, is it likely something Kodular is going to have to fix? I’m confident something must have changed with regard to how kodular is detecting screen size or resolution and/or how it’s calculating some responsive content, such as automatic component heights and widths.

1 Like

I have the same problem, in addition, I am facing the problem of extracting the apk and everyone else as well, and extracting the aab does not work at all.


I have emailed kodular support, but whether they reply or not is another matter!