setWebViewString not working

I’m having problem with the setWebViewString where it doesn’t seem to be working. I have a html with a link that calls a function in a js file (both uploaded into project). The function is as follows:

function callPicker() {

It serves as just a call for the WebViewStringChange event where I treat whatever I need treated (for test purposes, I only had a toast call to show the string itself). After clicking such link, nothing happened, I call the WebView.WebViewString via blocks to check the content and it remains empty. I set the string via blocks and the event is triggered as expected.

The thing is, the getWebViewString works normaly, as I tested a function where a link in the same html calls a function in the same js file (after I have set the WebViewString via blocks):

function showAlert() {

And the alert shows as expected.

I even have built the app and installed on my phone to see if it was a problem with the companion and had the same result.

Is there any known bug with such element?

1 Like

Please prepare an example as small as possible, which demonstrates this issue and add the project (aia file) into this thread together with exact instructions for how to elicit the error, so someone can take a look


Yes. I make a html file to show list of item. And want to get back value when user click on each item. I tested on appybuilder, thunkable…it’s working fine. But not get back string value on makeroid…and here is my html file. (1.7 KB)

something for @KodularCreator staff to check…

1 Like

It’s already fixed (at least for 1.2) as we added some new features to WebView now and it’s working fine with them


hi, i want to know when version 1.2 will be release?

We don’t know yet :sweat:

I’m sorry…you’re already worked so good ! Thanks makeroid team ! <3


Thanks for the attention. I didn’t even had time to respond until now (or send the requested files). But seeing a solution is on the way with the new update, I’ll wait and report back if anyting keeps buggy (else, assume the problem is solved, hehe).

Thanks for the dedication!

1 Like

Thanks for asking questions
And i can also want to know this
Than search
I know that mepaytm extension use this
Than know webview has “on string change”
I have use webview and remove mepaytm extension .
Both same