Sharing Component works fine in Companion but in App its failed

Please anybody help me to solve the reason “not working of sharing option in App but working in Companion Testing”

Is any particular permission needed for this.

My blocks are here…

blocks (1)
blocks (2)

What is the output of shown block in apk and companion

Second Method applied for same process till this problem solved by anybody.

Since it works in companion

Probably this one android.permission.WRITE_EXTERNAL_STORAGE

1 Like

already applied

1 Like

same issue. already applied [android.permission.WRITE_EXTERNAL_STORAGE] :pray: :pray:

1 Like

No need to write full you can use below block for Permission but problem exists of Sharing Component.

blocks (6)

blocks (5)

Just tried and it’s working as long as you don’t change package name

1 Like

When will this problem be solved. :pensive: :neutral_face:

Finally i have solved this Problem.

Now Everything working fine.

I used an Extension name TiafunSharing.

Correct Method is below


OR use TiafunSharing (Free Extension)

Also i suggest

blocks (8)

Edit: removed by MOD

The same thing happens to me since the last update of Kodular, in the companion it works well, but when installing it does not work

The only solution that worked for me is to use the TaifunSharing extension.

1 Like

Never post direct download link of a extension if it is not yours


Can you see what the problem is in this AIA? Plz :pray:
fffffff.aia (717.6 KB)


thank you :slightly_smiling_face: :slightly_smiling_face:

same here share component don’t work

Same problem here