Someone cute the power, Your apk couldn't be compiled

Hi, I am trying to generate the apk for my app and I keep getting this error.

May be I am wrong but I believe I generated the apk with the very same project before without problem.

I tried to remove all the screens but it didn’t work, what make me think that the problem is on screen1. I tried sugestions of others topics like change the icon, verify splash screen, but I couldn’t find the problem.

PrintGeneratorFree.aia (266,2 KB)


Kodular is unable to compile this project. 
The compiler error output was 
________Preparing application icon
________Creating animation xml
________Creating fragment xml
________Creating listview xml in res/layout/..
________Creating xml in res/drawable/..
________Creating splash png in res/drawable/..
________Creating colors xml
________Creating strings xml
________Creating styles xml
________Creating styles xml v21
________Creating drawables xml v21
________Generating manifest file
________Attaching native libraries
________Attaching Android Archive (AAR) libraries
________Attaching component assets
________Invoking AAPT
YAIL compiler - AAPT execution failed.
1 Like

I’ll make in a few hours a reboot of all our Compilers, some users also reported the same error
Hopefully it will be fixed


That’s exactly what I thought at first, @Diego but I made a comment at another post and someone made me think that the problem was fixed.
Sorry for opening an unnecessary topic

1 Like

I am still with this problem
Is it supposed to be solved already or the team is still working on that?

I have the same problem since 22/11 someone knows how to solve

I think i found what is happening! Actually when i use Enhance.Co Extension on my app it always get that error, but when i make an app without Enhance it works fine!
Maybe Kodular is created with a code that stops Enhance Extension?


I am not using this extension.
The only extension used is Component to Image , but even after I removed this extension the problem continues.
I believe it’s really a problem on the YAIL compiler. In others words, a bug on app inventor or kodular system.

Can you send me the AIA via PM to check it?

1 Like

That was the aia when the problem started (I may be wrong but I believe this very aia was working a few days before the problem started).

This is the same project after I removed extension and others screens:
PrintGeneratorFree_copy.aia (212,5 KB)

Thank you in advence, Diego.

Thanks, I was able to catch the error on the Compiler:

[java] INFO: ____Executing /tmp/aapt8527941574279050209 package -v -f -M /tmp/1543076938366_0.04213703169006133-0/youngandroidproject/../build/AndroidManifest.xml -S /tmp/1543076938366_0.04213703169006133-0/youngandroidproject/../build/intermediates/res/merged -A /tmp/1543076938366_0.04213703169006133-0/youngandroidproject/../build/assets -I /tmp/android3643739238430062668.jar -F /tmp/1543076938366_0.04213703169006133-0/youngandroidproject/../build/deploy/PrintGeneratorFree_copy.ap_ -m -J /tmp/1543076938366_0.04213703169006133-0/youngandroidproject/../build/generated/src --custom-package io.kodular.diego_barreiro_perez.PrintGeneratorFree_copy --output-text-symbols /tmp/1543076938366_0.04213703169006133-0/youngandroidproject/../build/generated/symbols --no-version-vectors
     [java] /tmp/1543076938366_0.04213703169006133-0/youngandroidproject/../build/assets/G1Logo.jpg: error: File is case-insensitive equivalent to: /tmp/1543076938366_0.04213703169006133-0/youngandroidproject/../build/assets/G1logo.jpg

It seems like you cannot use two assets with same name but different capitals
Can you try renaming either G1Logo.jpg or G1logo.jpg to something else?

1 Like

One thing so simple but at the same time I would never notice it by myself.
I guess I checked every thing but this.

Thanks a lot, Diego <3

1 Like

Great! :+1:

I’ve created this FAQ for other users who have the same problem: