Something went wrong, test works ok but export APK fails to compile

Hi, cannot generate APK for several days now.
Testing with companion works ok.
Error message is as below:

Kodular is unable to compile this project.
The compiler error output was
________Preparing application icon
________Creating animation xml
________Creating fragment xml
________Creating listview xml in res/layout/..
________Creating listview xml in res/layout-v21/..
________Creating xml in res/drawable/..
________Creating splash png in res/drawable/..
________Creating colors xml
________Creating styles xml
________Creating drawables xml v21
________Checking for firebase
________Creating provider_path xml
________Creating network_security_config xml
________Generating adaptive icon file
________Generating round adaptive icon file
________Generating adaptive icon background file
________Generating manifest file
________Attaching native libraries
________Attaching Android Archive (AAR) libraries
________Attaching component assets
________Invoking AAPT
AAPT time: 1.306 seconds
________Compiling source files
(compiling io/kodular/pctb2007/ALPRBRSSL/Config.yail to io.kodular.pctb2007.ALPRBRSSL.Config)
(compiling io/kodular/pctb2007/ALPRBRSSL/Screen1.yail to io.kodular.pctb2007.ALPRBRSSL.Screen1)
(compiling /tmp/runtime3163500755750213266.scm to
Kawa compile time: 1.802 seconds
________Invoking DX
DX time: 4.481 seconds
________Invoking ApkBuilder Failed to add /tmp/1638352781713_0.8090696230651829-0/youngandroidproject/../build/tmp/classes3.dex
YAIL compiler - ApkBuilder failed.

Am I doing anything wrong?
Assistance welcome.

Extensions used ? How big are your assets? How many screens ? Please provide more info

1 Like

Extentions: DateTools, TaifunFTP, TaifunImage
Assets: 3 (png) images totaling 580K
Screens: 2 (main App on Screen1, setup parameters on screen config)

Second screen is just a setup screen that collects system parameters and store on Tiny_DB
Initially the App worked with fix parameters.
Sometime during the design of the config screen this problem started and I switched to test with the companion to complete the config screen.
The App works ok while testing with the companion but fails to compile.


If you wish you can pm me your aia to check it

Ok, thanks.
The App uses a couple of tokens and private ftp credencials I am unable to disclose.
Is it ok?

Do not worry :slight_smile:

If you wish delete keys

I replaced private credentials as suggested.
removed aia by Mod beacause contained paid extension

I will check it

I found that removing the DateTools extension allows apk to compile with no errors. Updated extension to latest version 6.1 and still error occurs. I found this

Maybe the developer @vknow360 might help you

The problem is that it is not possible use DateTools extension if you use FTP component or any FTP related extension (except FtpClient extension).


Hi, I used FtpExtension before but had to abandon it because it only works over WiFi and not via GSM.
Datetools I use exclusively because I need to know local timeZoneOffset.

Any way out of this?

You mean GTM +2:00 for example?

If yes maybe you could use clock component

Please wait till tomorrow.

See this has the same function

Did not know I could use such construct.
Will try, thanks.

1 Like

Have a look at

Date and Time Patterns

Indeed removing DateTools extension and using Dora’s suggestion sorted out the problem.
It now compiles successfully.
Thanks you people for your time.

1 Like

If problem solved mark solution :white_check_mark: in order to help others with the same problem

1 Like