Something went wrong

I have completed my app building but when i export it it is showing “Something went wrong” please help me guys!!! Its very urgent. It is very important for my life guys. Please help me guys!!!

When I click on view log it showed this below information

Kodular is unable to compile this project.
The compiler error output was
________Checking dangerous extensions
________Preparing application icon
________Creating animation xml
________Creating fragment xml
________Creating listview xml in res/layout/…
________Creating listview xml in res/layout-v21/…
________Creating xml in res/drawable/…
________Creating splash png in res/drawable/…
________Creating colors xml
________Creating styles xml
________Creating drawables xml v21
________Checking for firebase
________________Firebase components found.
________________Firebase config file error.

Please helppppppppp!!!

You Need To Upload “google-services.json” file to your Assets.

1 Like

I have already uploaded.
May I keep my blocks

might be the name would be wrong
check that again

1 Like

which name

If you have uploaded the google services which had name like "google-services.json(1)’, then it’s not gonna work. Check if name of the file is ‘google-services.json’.
Hope it helps… :slight_smile:

1 Like

name of “google-services.json” file

Share Screenshot of Assets Page.

1 Like

ok iam sending the screenshot


Thank you all of you. My google json file has like this google-json(1). Now i downloaded json file again and renamed it worked thankyou a lot guys especially for @golumaths100 and @ADDYLIN. Thank you guys…

1 Like

You are welcome. If it helped you, then mark answer as solution so that it will help others. :slight_smile:

1 Like

I instead uploaded the right file “google-services.json” but it doesn’t work and gives me the same error… how can i resolve? google services error

Whats your Package Name in App,
and in Firebase.

They need to be Same.


Ok thanks so much

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.