Storing large text in Airtable

I am making an app in which I have to upload images also. I am using airtable to store my data, but we can’t store or upload any file from our apps in Airtable.
So I am converting those images to base64 string and then trying to store them in Airtable. But I am unable to upload that also (maybe because of large text of base64 string).

Anyone know how to upload large text (like that of base64 string) in Airtable. Or is there any alternative or different way to upload files in Airtable?

I know I can use airtable with cloudinary, but I want to do this as simple as possible. So that my clients can use it without looking after both airtable and cloudinary.

I don’t think airtable doesn’t support large text… There must be some different issue… Please show your blocks

I can’t acess my pc right now and it’s next to impossible to open such projects on phone.
I first try to store small text and it stored successfully on airtable. Then I try to store base64 encoded text and I wait for 10 min. but nothing happened.

OK once you get access to laptop just try storing large text(not converting into Base64)… If it stores then it’s an issue in your code

1 Like

Try this in your pc

1 Like

Screenshot_2020-07-14_00-54-20 Screenshot_2020-07-14_00-55-39

I tried these 2 methods, both didn’t work. I also try to store large text copied from Wikipedia (around 70k in length) and it also didn’t store/upload in airtable. So that means length is the issue here?

Doing this, only increase how much you can view. I don’t think this have any effect on uploading large text :thinking:

Have you tried using your app or manually placed in the cell?

I tried by my app
I can paste any large text manually in airtable, but if try to store that same large text by app then it doesn’t work

Try manually copying the large text and placing it into a cell of spreadhsheet… if it works then it might be a problem with your code and if it doesn’t then use google spreadsheet

I already said this in my previous comment
Yes I am able to paste large text directly/manually in the airtable cell. But when I try to do this by app nothing happens. And using the same blocks when I store small text, it works :disappointed:

In case use your app to store large text but not base64 text use the text of wikipidea that you placed in airtable so we’ll get an idea whether it a problem with base64 or soemthing else

yes, I also tried to store that wikipedia text by app, it doesn’t work.

then try to use google sheets instead of airtable however the limit of google sheet for characters for one cell is 50000

And if you have the text greater than 50000 then you can upload the image on drive and after that place the link in google sheet

1 Like

but I can use airtable with cloudinary instead of google sheets with drive
thx anyway :smiley:

Yeah sure but i would recommend using google sheet as you can the number of people that can access together is 100 people per second but for airtable its 5 person per second and also in airtable you can only store 1200 records

yes, that’s true
but I already made my whole app on airtable
so it will take many days to change it to google spreadsheet now

in future I will use google spreadsheet, thx :upside_down_face:

1 Like

Airtable currently support 20K+ words in single row

1 Like