Taking a Screenshot: Error 908: The permission WRITE_EXTERNAL_STORAGE has been denied

Good morning guys!
I’m sorry for the inconvenience, but I’ve done a lot of research and haven’t found a solution.
In my app the user has to take a Screenshot but I have a problem with permission for this function, I’ve already tried many different ways that didn’t work.
I would be very grateful for some guidance

Use inbilt screenshot feature for disable screen shot permission it’s very simle not required any extension

What exactly is the problem?
Do you get an error message?
Does taking a screenshot work or is the issue about sharing the screenshot?


To ensure that the problem is not the sharing, I removed the sharing, but the error continues.
It seems to me like it’s a permission error

Could you please show me, I don’t know how…

A post was split to a new topic: Image Picker: Error 908: permission READ_MEDIA_IMAGES has been denied

The is no WRITE permission on Android 11+, so you can’t require it there and it is also not needed (esp not for the ASD). So request only RECORD_AUDIO and CAMERA.

Don’t ask Write permission

Guys, good morning! I hope you are well! I’m having trouble taking a screenshot after the update.
Does anyone have any tips to help me?

I’m doing it like this… And it’s giving this error
What am I wrong?

You are using the FormatDate block twice… why? This does not make sense…

Also where exactly is the issue? It looks like taking the screenshot works fine? Can you confirm?
Try a full path for sharing, i e add file://
Also what about using Do it to debug your blocks? A complete error message would be great to have…

use Do it to debug your blocks, see also tip 4 here App Inventor: How to Learn | Pura Vida Apps
see also Live Development, Testing and Debugging

Due to lack of attention, the block was duplicated, but now it works, but the screshot was generated that way…

this is a known issue, see also Unable to take screenshot of Google Maps

why don’t you use the built in screenshot component as you started in the beginning of this thread?
You might try again and provide a screenshot of your updated relevant blocks using the built in component