The operation > cannot accept the arguments: , [1], [*empty-string*]

I am following a video tutorial to copy a quiz app, which link is as below.

It consists of Screen1, Main, Study1 and Study2 so far. First three screens (Screen1, Main, Study1) have been successfully run on mobile. Next task is to copy the Study1 screen and make new Study2 screen (using the option to copy screen in kodular creator). As shown in video there was nothing to do more than that and Study2 also will work as well as Study1. But this is not in my case. I am attaching the relevant screenshots. Please help, if possible.!

This is block of screen 1

Screen1|587x209

This is 2nd screen (Main) block.

This is 3rd screen (Study1) block.

Upto this level app is working fine, here are some screenshots

In companion in mobile (showing all the questions from firebase realtime database)

Relevant firebase realtime database

But when I copied Study1 and made Study2 screen, it is not showing data from firebase, other than that in the title bar Total no. of question figure also missing in the companion, however in designer, it is not missing.

After Clicking ‘Next Question’ button, it is showing error as stated in the subject of the topic

Relevant firebase realtime database

Here is Realtime database rules

For further details here are .aia file

Quiz_App.aia (489.9 KB)

Hope above will be sufficient to help me, thanks

According to the message, in some block using > is empty.
Next Procedure , Maybe :

1 Like

Your global No is empty

2 Likes

Thanks Sumit for your time and effort,

but I really don’t understand much about these things. I am just trying to learn by copying youtube videos. You can get that I don’t know even basic concepts.

But for now, if you are telling me that global No is empty ( :smile: I don’t know how to fill it) then it is empty for the Study1 screen also, which is working fine and not showing any error. It is only Study2 screen which is throwing error, which just copy of Study1 screen.

thanks again

Maybe ur firebase is getting value on study1 but not getting on study2

Did You Try verify ?

?

1 Like

but that is having value, I have attached screenshot for that also.

Do you mean to say, that there firebase may not get value even after having value in it ?

If this can be the case, should I try to recreate Study2 child after deleting it ?

thanks

It means that you have an empty value in a comparison >.
So, you should check:
-Why
-When
-Where
:thumbsup:

1 Like

Thanks for your help

I even don’t know about it, but now I will see what it is and what can I do with it in this case.

thanks

When you get something from the tag, check it, put it on a label and see the content.

1 Like

Ok,

thanks for your knowledge and concern. I will try after going through the terms used in this conversation.

thanks again

Thanks Rogerio_Rios,

My problem is that the same block is working fine for Study1 screen but not for Study2 screen, both screens are perfectly connected with database as well.

Even though the “value if Tag Not There” is empty, but it is working fine Study1 screen, but throwing error in Study2 screen. If blocks are right then it should work for both screens, but if it has some error, then why the error is not Study1 screen.

I have tried too much but could not find, on other hand the video maker has no issues at all with the same blocks.

Have you checked with my .aia file ?

thanks again.

Check, for example, the variable “No”. Put the value of this variable to be shown in a label. At some point it may be empty, look at your blocks. Forget if the algorithm is working on the other screen, it will not solve your problem.

Thanks Rogerio and Sumit,
After your suggestion, I just checked all tags and changed without thinking anything, and one change worked.

Now every thing is fine, what I did is as below -

  1. I changed global number to global_No at one place in Study2 which worked fine for all other screens also (from Study2 to Study6). [AS SEEN IN PICS]

  1. But when I changed global number to global No at the same place as above in Study1, it didn’t work. It showed nothing alongwith all the values from database at start of the screen, after clicking the “Next Question” button, it worked fine as before. So I am not changing anything in Study1 for now as it is working fine with no change.

For now problem is solved, but I really don’t understand what has happened, why a change is not working for Study1, which is fine for all other Screens (Study2 to Study6), please check images.

I shall feel obliged, if you could explain, what actually happened in my case. (It is strange that video maker had no such issue).

thanks a lot.

Friend.
And this comparison?
Please, Study your blocks
You should not check a solution that you have not solved. (this will not help other users) The error message clearly shows you the> sign, the number 1 and empty. The message informs you of the comparison between 2 things and one is empty. Your solution is to look for why this variable is empty.

Thanks but I don’t know if there is something wrong. For now, my problem has been solved. If there is anything you suggest, will be valuable for me.

thanks to be with me.

Well, you think you got it. OK. One mistake can lead to another …
#off-topic
Sorted out

Thanks friend, but as I already told I don’t understand these things, but I assume there is need to change global No with global number, do I get that ? :smile: