Unable to Compile app without any error: The compiler error output was

My app has no errors
Some it is compiling and somtimes not
ERROR: View Log
Kodular is unable to compile this project.
The compiler error output was
Not showing any error
The error is not in my app

There could be many reasons behind that…
I think that, your internet connection is very poor…

No my internet connection is very good
but my app is heavy

Give us more info to check if there are any faults… The provided information isn’t sufficient…

Some times works perfectly
and some times unable to compile
It stucks at 0% Drawing app icon for a minute
And says unable to compile (error)

when viewed log:
Kodular is unable to compile this project.
The compiler error output was
Unknown error

my app is haevy (so many blocks)
if it is the problem then it should not be able to compile all the time
I think server is busy, Server may not become busy because I think Kodular runs on Google servers

1 Like

Again got error
Sometimes compiles perfectly

1 Like

Then post one of your “sometimes compiles perfectly” APK.

this is the kodular system error, even i am facing the same problem.

How heavy is your “so many blocks”?

How many blocks and components do you have?
(Hint: to find out how many you have, right click in your blocks page, one of the option would be “delete XXXX blocks”; the XXXX number will be how many blocks there are).

I have an app that has about 6000 blocks in one screen, and it does compile.
That same app compiles in Thunkable Classic API26, but NOT in their API28 compiler (their API28 compiler is bugged down, can only accept about 2000 blocks).

Bottom line is that if it compiled yesterday, and you are compiling again today, that is evidently because you just changed something. Is it possible that you are just so close to the upper limit of what the system can handle that you may end up exceeding that limit?
Every component you have has a memory footprint, and simpler components, like a label, take less memory than a more complex one, like a text box, since a text box has more attributes that have to be defined and retained.

1 Like

I tested your aia that you shared on Slack and I noticed no difference in companion or apk, you can PM me another one if you want me to test

1 Like

Umm i haven’t share the .aia of my project but I’m doing it rn. Give me a minute.

Edit: sent to our workspace.

It happens with me also just reload your tab and open project, then compile your app again.

1 Like

let’s see if devs can find a way to fix this!

I’m having the same issue today. it compiled fine yesterday. I made a few minor changes today that should not be throwing errors. I got it to compile once. every other time I get an unknown error.

ho degli scremi con errore non si aprono cosa devo fare?



1 Like

watch your writing correctly,
do not use spaces in the text
I also experienced the same problem.
if the title must use better spaces, give a title like this (example Apps_Project) Good Luck

Me too have the same problem after I collapsed my blocks.
I collapsed my blocks and expanded after 1 minute. I was just testing the collapsing option. But after expansion I am unable to create my Apk. It is showing error from 0 % and the log is ;
Kodular is unable to compile this project.
The compiler error output was

Without giving any info about your app we can not help you.


My problem Solved.
I just waited for 1 hour and tried. Thank you all.