Unable to compile

Apologizing for my bad English.
I’ve searched in community for this issue, found several solutions but nothing is working for me. Error compiling the project.

Kodular is unable to compile this project.
The compiler error output was
________Preparing application icon
________Creating animation xml
________Creating fragment xml
________Creating listview xml in res/layout/…
________Creating listview xml in res/layout-v21/…
________Creating xml in res/drawable/…
________Creating splash png in res/drawable/…
________Creating colors xml
________Creating styles xml
________Creating drawables xml v21
________Checking for firebase
________________Firebase components found.
________________Firebase config file successfully added.
________Creating provider_path xml
________Creating network_security_config xml
________Generating adaptive icon file
________Generating round adaptive icon file
________Generating adaptive icon background file
________Generating manifest file
________Attaching native libraries
________Attaching Android Archive (AAR) libraries
________Attaching component assets
________Invoking AAPT
AAPT time: 1.124 seconds
________Compiling source files

Okay, so let me tell you few things first, yesterday also I exported this project and it worked fine, but today I tried to import a custom font typeface, and the issue occurred. Then again I have tried to export after removing the custom font typeface file, but didn’t worked. There is no issues with package name, app name or app icon, as it worked fine yesterday and I didn’t made any change except trying to add custom font face. I’m sharing the .aia file with you. Due to privacy reasons I have removed the firebase links and auth token, but while exporting time I triple checked everything but still getting the issue.
CSApp.aia (481.8 KB)

Have you tried again to compile…
I think the problem is with busy server.

Try this, there was a project within a project
CSApp.aia (219.6 KB)


Thanks for your reply Ariyan, I have tried compiling more than 6 times, and then to determine whether it is a kodular’s server issue or not, I tried to compile my different project and that exported successfully. But this project still having issues.

Ooo! Yes, @dora_paz the Old File was 481.8Kb and Yours one is 219Kb. There’s a Big Suspense

Hey, @C.Saikat Follow the aia sent by @dora_paz

1 Like

Because as I said project within a project

1 Like

Thank you sooooooo much Dora, it is absolutely fine now. Thanks a lotttt for your help. Can you just tell me how you understood that there was project within a project?
Thanks again !!

Yes yes! I understood what you have said :grin:

But I didn’t check the AIA and just See the Log, even he didn’t expose the full log ( may be ).

Ariyan, I have shared the full log only.

1 Like

In this picture see there’s 3 folder of the project and one individual project folder named io.shreyash.phase

Ooo Really So Kind of You. :grinning:

Actually I have imported an extension called “Phase Animation” but I didn’t used it.

That’s not a issue, have your Problem solved or not. If solved then treat us a big meal

& Thank You so much @C.Saikat

See here, a guide on how to solve such error

1 Like

A post was split to a new topic: Unable to compile project

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.