Unable to Export apk

Hey guys i was tring to export my app but it is showing build failed. i tried too many times then it started compiling but it is showing this error

Kodular is unable to compile this project.
The compiler error output was
________Preparing application icon
________Creating animation xml
________Creating fragment xml
________Creating listview xml in res/layout/…
________Creating listview xml in res/layout-v21/…
________Creating xml in res/drawable/…
________Creating splash png in res/drawable/…
________Creating colors xml
________Creating styles xml
________Creating drawables xml v21
________Checking for firebase
________________Firebase components found.
________________Firebase config file successfully added.
________Creating provider_path xml
________Creating network_security_config xml
________Generating adaptive icon file
________Generating round adaptive icon file
________Generating adaptive icon background file
________Generating manifest file
________Attaching native libraries
________Attaching Android Archive (AAR) libraries
________Attaching component assets
________Invoking AAPT
AAPT time: 2.417 seconds
________Compiling source files
(compiling io/kodular/sonuansaari312/FB_EmailLog/Result.yail to io.kodular.sonuansaari312.FB_EmailLog.Result)
(compiling io/kodular/sonuansaari312/FB_EmailLog/Home.yail to io.kodular.sonuansaari312.FB_EmailLog.Home)

ERROR: io/kodular/sonuansaari312/FB_EmailLog/Home.yail line 42: duplicate declaration of ‘Home$BackPressed’

ERROR: io/kodular/sonuansaari312/FB_EmailLo g/Home.yail line 42: (this is the previous declaration of ‘Home$BackPressed’)

Kawa compile time: 81.774 seconds

See this block is present in multiple times , check up in all screen. Or in some screens some empty blocks are there, so that this error occurs…

Especially in Home screen mistake is there. Check up slowly one by one

thank you. @Still-learning You helped me a lot today and yesterday. back pressed event was used 3 times :slight_smile: but there is no error showing. like block show that if any event using multiple times then it shows red cross error but it was not showing. after i watched all then it worked. thank you once again :slight_smile:

1 Like

This post was flagged by the community and is temporarily hidden.

Official language is English. Pleas change your post using Google translate if not your post will be flagged

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.