[Updated 2] My sql data is not getting properly

I m working on my sql database using @Taifun method and script
My tables set is like
Id | Poetry
And i added data like
اب دلوں میں کوئی گنجائش نہیں ملتی حیاتؔ

بس کتابوں میں لکھا حرف وفا رہ جائے گا
(urdu poetry)
When i tried to save it in text data type then when i get it in my app sometimes it mixed both id and poetry with same sorting method once i was getting text and at other time it is showing id (if u did not get my point that what i meant by sorting method then my given blocks will help you to understand )

Then i tried Blob data type now its not mixing but it only shows one line of poetry as follows
اب دلوں میں کوئی گنجائش نہیں ملتی حیات
(it also happenes when i used text data type ) but i have saved two lines of poetry as i mentioned above
Now please help me where is the problem and to overcome it


i think its happening due to spaces in poetry text bcz after removing all the larger spaces we get normal results
Plz check on your side and provide solution how can i store poetry with spaces too
My main block is here

Updated (2)

Here is my aia file plz try it if it can be fixed
mysql.aia (9.6 KB)

what kind of block is “responseCode” ?

EDIT: Also “responseCode” is a number, then it gets the error in the join section, because it’s not a string either!

But looks like “responseCode” is not a number either, because it gets the error in the math section of blocks.

So please, as said before, show ALL blocks, so we can see where the error is.


1 Like

Also, what is “responseContent” for a block? show please

1 Like

If you go to e.g. https://pastebin.com/raw/cxvYb45A, the response Content would be:

Afghanistan Albania Algeria American Samoa Andorra Angola Antigua and Barbuda Argentina Armenia Australia Austria Bahamas Bahrain Bangladesh Barbados Belarus Belgium Belize Benin Bermuda Bhutan Bolivia Bosnia and Herzegovina Botswana Brazil Brunei Bulgaria Burkina Faso Burundi Cambodia Cameroon Canada Cape Verde Central African Republic Chad Chile China Colombia Comoros Congo, Democratic Republic of the Congo, Republic of the Costa Rica Côte d’Ivoire Croatia Cuba Cyprus Czech Republic Denmark Djibouti Dominica Dominican Republic East Timor Ecuador Egypt El Salvador Equatorial Guinea Eritrea Estonia Ethiopia Fiji Finland France Gabon Gambia Georgia Germany Ghana Greece Greenland Grenada Guam Guatemala Guinea Guinea-Bissau Guyana Haiti Honduras Hong Kong Hungary Iceland India Indonesia Iran Iraq Ireland Israel Italy Jamaica Japan Jordan Kazakhstan Kenya Kiribati North Korea South Korea Kuwait Kyrgyzstan Laos Latvia Lebanon Lesotho Liberia Libya Liechtenstein Lithuania Luxembourg Macedonia Madagascar Malawi Malaysia Maldives Mali Malta Marshall Islands Mauritania Mauritius Mexico Micronesia Moldova Monaco Mongolia Montenegro Morocco Mozambique Myanmar Namibia Nauru Nepal Netherlands New Zealand Nicaragua Niger Nigeria Norway Northern Mariana Islands Oman Pakistan Palau Palestine Panama Papua New Guinea Paraguay Peru Philippines Poland Portugal Puerto Rico Qatar Romania Russia Rwanda Saint Kitts and Nevis Saint Lucia Saint Vincent and the Grenadines Samoa San Marino Sao Tome and Principe Saudi Arabia Senegal Serbia and Montenegro Seychelles Sierra Leone Singapore Slovakia Slovenia Solomon Islands Somalia South Africa Spain Sri Lanka Sudan Sudan, South Suriname Swaziland Sweden Switzerland Syria Taiwan Tajikistan Tanzania Thailand Togo Tonga Trinidad and Tobago Tunisia Turkey Turkmenistan Tuvalu Uganda Ukraine United Arab Emirates United Kingdom United States Uruguay Uzbekistan Vanuatu Vatican City Venezuela Vietnam Virgin Islands, British Virgin Islands, U.S. Yemen Zambia Zimbabwe

1 Like

response code is a number and working perfectly my problem is just its not showing data in a proper way mean it should show only poetry when i place 2 in my first index list block
and it should show only id when i place 1 i.
but it is intermixing at both numbers mean when i place 2 it shows both id and poetry

it is happening due to unknown reason i think its an error in @kodular because whenever u try to use aia with web component it always shows arror in blocks but everythings works perfectly

Only you replied no one asked before
And i’ll send u aia for furtuer details morever everything is ok working perfectly
it is due to spaces because i trird by removing spaces and using encoding and decoding method in these cases it worked fine but when i store data with spaces and without encodind and decoding it starts showing errors
somehow Lis blocks are unable to select data perfectly
Plesae have eyes on it

i did not get your point but you can check here

Where did you get that info from?

1 Like

I don’t think so. You have to look up your variable changes, there may be a bug.

For my knowledge, this error is the only acceptable and ignorable one:

blocks (5)

I just said that because I’m not the only one who is seeing that
:man_teacher: :eye:

No, not at all. I think you can’t use that block in a definition, but I am not sure. Click on the X icon to find more info.

1 Like

I already did that and I am using this block in nearly every project I make. It’s not a problem at all. I learned about this in a tutorial and it just shows the error, but it is

and it works!

1 Like

I tried it by myself
If u have doubts then u can try too

1 Like

Same is in my web componet case it is also ignoralbe and acceptable bcz i m using it.

1 Like

Ok, come on. Let’s do not hijack this topic.



1 Like

Hmmm who is hijacking … My project is very simple and there is no other error at all the only problem is in my mentioned block or m not sure it may be a problem in PHP script by @Taifun or list components are showing this strange behavior

1 Like

Edited ;
plz check it now i have updated and provide aia file too now try to fix if you gyz can help

Don’t tag people to get attention.


I will do later, now I have other work to do.

1 Like

sure m waiting for your turn

Did you try my aia ??