Web_Viewer ".load HTML": Companion crashes

I tried using Web_Viewer.
If I use Web_Viewer to load a web page (example Button2) it displays without any problem.
If I use Web_Viewer to load HTML text (example Button3) Companion crashes.
I verified that the problem is old.
Is it possible that no one has fixed this bug?
Can anyone use the Web_Viewer “.load HTML”?

Well, that’s odd. I think you can try to simplify your HTML to see if there’s a specific part causing the issue. Sometimes even a small typo can cause big problems. Try to ensure your HTML is well-structured and doesn’t have any missing tags or quotations.

WebViewer has bug, for a long time.
You can search in community to find similar crash issues.

Nothing to do with crash.

1 Like

blocks (5)
Would you say it’s simple enough? It still crashes!!!

Have you read above reply ?

I already checked the community and didn’t see any solution.

You might have missed some relevant posts.
There are two major solutions available:

  1. CustomWebView
    More features, more stable, quick support

  2. NoFileHtml
    ✨ [Free] NoFileHtml - view html without files - Extensions - MIT App Inventor Community
    Continue using WebViewer

So there’s nothing to do. The first detection of the bug was in 2018. I hoped that in 5 years someone had solved or found some method to circumvent the bug…

I was hoping that the Web_Viewer component bug would be fixed or worked around without having to use new extensions. However, in my research I had not seen the NoFileHTML extension which seems to come between the Web_Viewer component and HTML text. At first glance it seems to work correctly and to fix the bug well.
Thank you very much to everyone and in particular to vknow360.

Try this extension :