WebViewer Bug with Maps

WebViewer does not load maps
I had a personalized javascript google map and i tested with other plataforms. but does not work here.
this is the link
Q2 Autolava2 --> If you open in a browser will not show anything because has a Set and GetWebViewString Javascript method.

I tried with google maps link and dont work either. Google Maps

i dont have blocks, only url home parameter:

This is the WebViewer from AppyBuilder working.

I think that one of the problems could be not has https. plese check this!!!


No answer? :roll_eyes:

With the lastest update in webviewer i found the cause for this issue with console log event.

i clear cache, enable location reset companion and still continue without load.
i hope to find the problem.

note: i use navigator.geolocation in javascript code

Turn on “Prompt for location permission” designer property and use related blocks

1 Like

it doesn’t work.

Me pregunto si esto lo arreglaran algún día? no he vuelto por acá porque prácticamente mi proyecto quedo parado por esto. No me sirve usar el mapa nativo.

Sorry for the really long waiting time…
I finally fixed this bug for upcoming release.

Thankyou so much! it works… this year i am going to promote kodular in my youtube channel.


June 2019. I am presenting the same error. I have a google map with javascript that appinventor works well, but in kodular it looks blank.

Could you send a screenshot of the properties panel for your webviewer?



solved issue.
In the properties of the web viewer component, advanced. the 3 options must be enabled and that way it worked for me.
Thanks to mirxtrem_apps.


1 Like