What is the correct path to read ASD files now?

I’m trying to view an image. I am downloading an image file from ASD (which is there) and I am unable to display it.

I tried the full path. With “file: //” without. No result.
I’m testing on Android 11.
Of course, everything worked fine until the kodular update.

file:// does not work.
For Android <=10, file:/ read and write access, file:/// for read access
For Android =11 file:/// - only read access, file:/ will not work for android 11
Both cases are for activity starter, but should work.

Also, if you are getting any runtime error then read this thread, solution is also given

Unfortunately, neither of the following works. The image is not being read.
Any other hints?

Wait, few minutes

TestP(2).apk (5.1 MB)
Working on Android 10
Let me know, if this is working on Android 11

I’m going now. I’ll be at home, I’ll see why it doesn’t work for me. your application works.

TestP.aia (8.2 KB)
AIA File, you can check it.
file:/ or file:/// didn’t work.


I see Deep Host extension which I am sure is quite outdated.

1 Like

What does Label1.Text return?

Now, wait a minute. I just got home and I can check everything out.

Unfortunately it does not work.
I checked everything I could.
The picture cannot be loaded.
Paths are correct.
Pictures are in ASD.
I cannot display them.
I have no more ideas.

Post a screenshot so we can see what Label1.Text is showing.

I sent you the AIA file yesterday.

I have now removed all components from the application and only left one.
It still doesn’t work.
The whole application looks like this:

I only left loading the first map during screen initialization.
The picture is not displayed.
Strange because the sharing component takes an image from the same path.

UKF_test2.aia (262.0 KB)

I also upload the AIA file if someone wants to test.

Yes, there seems to be a bug with the Image component. It is no longer possible to access an image from the ASD.

Try this: UKF_test3.apk (5.9 MB)

Now can see the map.
How did you do that?

after download some file to Asd, i checked with File.Exists, it returns false.

No, it returns true.

I used an extension for it (Picasso from @vknow360).

1 Like

I understand that I have to wait for kodular to correct this error?
The picasso solution is weak.
It is not possible to share the picture.
loading pictures works sometimes, sometimes not.
Overall a failure with this new codular.

What do you mean? Picasso is great and does exactly what it should.

Did you try my APK?

I tested it on Android 9 and 11.

1 Like

How so? Elaborate more.