Works in Companion, but not in Apk (Copy/Move a File from ASD to ASSETS)

I tried to copy/move a file from ASD to ASSETS and it works in companion.
But it doesn’t works in Build APk. Let me know what should i do, @Taifun @vknow360 tried with both of your extensions Taifun File and File Tools extension and it doesn’t work in APK.

The assets are read only,you can’t copy or move a file there

But in Companion it Works and so i tried all methods on APK, but none works :rage:

Write a bug report to our friendly Kodular team then and tell them to fix the companion
In the end, assets will be read only, also for you


You are copying file from Asd to Asd. No assets involved in your blocks.
Check ’ Do it ’ result of paths to see where they resolve.

As per your blocks, i can see that you are copying file From ASD to within ASD but in a custom folder “assets”.

If the folder exists in your ASD this should work without any issue, because its a normal folder in ASD, (not actual app assets folder).

If you want to copy file in actual app assets then its not possible once apk is build, may be possible by decompiling Apk.

That path is the Apps “Assets” path, so it’s not possible.

but i want to set Lottie to custom paths, can we do it by any methods.

That is Companion’s asset path for testing.
In apk, assets don’t have a path.


Thanks a new knowledge gained.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.