YAIL compiler - DX execution failed.after updating to Fenix 1.5.4

I dont think, removing extensions is a solution. Not all extensions have alternative. What is a solution get the release fixed?

1 Like

Ask the extension developers to fix the extensions.

1 Like

Some of the extensions are bit old, I dont think there is any support anymore.
I have 10 extensions being used.

Then you need to find alternatives or pay extension developers to create new ones for you.

Good afternoon!
hey, I think actually recommending removing extensions to fix a more complex problem is not the best guideline or solution!

My project uses updated extensions that are very popular among developers, had numerous problems, when compiling, DX, etc…
I created a new project, it includes the same extensions and some basic functions and it compiled and installed without problems.

The probelam were the extensions?

I’m looking for a way to solve it myself, if I need to import what’s possible and recreate what I can’t, but maybe the problem is elsewhere!

1 Like


I think… but, how can we import UI?, this can be the more difficult, the block we can upload drop png picture blocks.

hello I removed a firebase_storage extension that was causing an error. And back to normal. I’m using a deep host extension, generate.pdf with no problems. I was very upset that they removed the admob and replaced it with ad manager because of the restrictions. I can’t add admanger because the apk doesn’t compile, an error happens.

And the real cause was mismatch of names

1 Like

Missed that …need better :eyeglasses: :slight_smile:

1 Like

Still Not working for Mee AAPT Error is Popping up

Meu projeto está com esse erro:

O Makeroid não pode compilar este projeto.
O compilador informou o seguinte erro
________Preparing application icon
________Creating animation xml
________Creating fragment xml
________Creating listview xml in res/layout/…
________Creating listview xml in res/layout-v21/…
________Creating xml in res/drawable/…
________Creating splash png in res/drawable/…
________Creating colors xml
________Creating styles xml
________Creating drawables xml v21
________Checking for firebase
________________Firebase components found.
________________Firebase config file successfully added.
________Creating provider_path xml
________Creating network_security_config xml
________Generating adaptive icon file
________Generating round adaptive icon file
________Generating adaptive icon background file
________Generating manifest file
________Attaching native libraries
________Attaching Android Archive (AAR) libraries
________Attaching component assets
________Invoking AAPT
AAPT time: 0.961 seconds
________Compiling source files
(compiling io/kodular/vinnibento11/Juvi_Music/Configs.yail to io.kodular.vinnibento11.Juvi_Music.Configs)
(compiling io/kodular/vinnibento11/Juvi_Music/Playlist.yail to io.kodular.vinnibento11.Juvi_Music.Playlist)

ERROR: io/kodular/vinnibento11/Juvi_Music/Playlist.yail line 11: no matching syntax-rule for _

Kawa compile time: 1.413 seconds

1 Like

We have a fix for this, but it lands with the major update (possibly, mid-end of May).


hi guys

Sorry for my english!

in the search to solve the possible incompatibilities generated by the recent update, I found something even more bizarre.

a project that used to run and compile normally and now does not compile anymore, continues to show the error:

________Invoking DX
YAIL compiler - DX execution failed.

When disabling half of the code blocks, it compiles again, without removing any extension, at first they were chosen blocks that were part of the same logic, but in a second moment, I randomly disabled blocks up to a number similar to the first time and the project compiled without problems again, but when enabling an extra block, the click of a button and it returned to show the error DX execution failed.

Has there been some kind of block limit implemented or something?

what I narrated refers to screen 1, but in the same project there are other screens with 5 times more blocks and they don’t seem to interfere!

Sorry that my comment seems like a git, but I’ve been trying to find a solution to the new problem!

Good weekend to everyone!


i want to change background color of arrangment, lbl etc but it show error
is there any solution


hi guys, i have the same problem, can u fixed it? thanks

There is always a alternative for most of things. You can try other app builder where Deephost’s MySql extension is working flawlessly. That extension is indeed very helpful

the other alternative is to use the web component


A post was split to a new topic: How to fix problem: DX execution failed

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.