A problem in Build failed ! Google AdMob components have been deprecated , please switch to Google Ad Manager

Admob Components no longer support if you still want to use admob you should need two things

  1. Kodular premium subscription
  2. Admob ads extension

b058a0b879016e23407e7830d7686f519af03fc1 - Copy (4)

Please stop spamming the topic and follow the suggestions provided. You have been told you need Premium and AdMob extension. Are you using an AdMob extension?

. has been deleted addition

Please post in full sentences and make it clear what you are doing, that way we don’t need to guess.

I am guessing you have deleted the AdMob component now. If you want AdMob you can use an extension. Search the forum for free and paid ones.

Even if you are subscribed to Kodular Premium, you can no longer use the AdMob components. If you wish you can use an AdMob extension (only Premiun users can use ad extensions).

I am facing the same problem now , have you solved yours please help me out

it does not look like you read the answers in this thread, especially this one


I have removed all the extensions still this problem is happening i don’t know what to do , this is my biggest project and suddenly this is happening

And currently i am not using any admob extension even

list all the extensions and components you are using

is your issue solved same problem happen with my project also…

yes ,it was happening due to an extension

name of extension please

Please share the procedure, i have the same issue, thank you.

The solution which i found for this was export the project open it in winrar and remove the screen which is creating the problem and reimport the same screen from the old aia of your app if you have either create the same screen again

1 Like

This post was flagged by the community and is temporarily hidden.