AAB Upload Unsuccessful, Requires Target API 31


I am trying to upload an AAB to my Play Store but I have gotten an error that I must target API 31, whilst Kodular’s is still on 30. So, I did some workaround.

I have read these topics:

I tried to change the manifest by decompiling the APK, added android:exported=“true” and changing targetSDK to 31 as suggested by @bodymindpower in his/her post, recompiling the APK, and making it to AAB. But, the problem comes when I am in the process of making it to AAB, I used both the Android App and PC version of this app (Convert APK TO AAB File - Guides - Niotron Community), it does not make me an outcome (the AAB itself), it will either just show please wait indefinitely/forever or showing an error that the bytes are not the same (The message says this:)

I have tried using another method, and that is with vulpecula

The AAB is successfully created but when I upload it to the Play Store, it says that it is missing the ‘android:exported’ property set.

So, what workaround should I do to develop proper AAB?

Thank you.

Thanks for considering Vulpecula!

At the time, I didn’t realize that android:exported had to be set on activities to be launchable.

I never uploaded Vulpecula source to GitHub, so it would take a few days to get it back and running, but it’s doable so long as you don’t need to update your listing ASAP.


Hello there @hammerhai ,
Thank you for the response.

I see that it may cause a problem. But, your app is all nice when it will later implement the android:exported=true properties. It is already having nice features such as permission checking and instant AAB creation with SDK 31 as target.

I am really looking forward for the update!

1 Like

Use this tool’
DevzStore : Enable Api 31 in your app

Hi Hammerhai,

I also really love the work you did the Vulpecula tool, with the recent Kodular update addressing the API 31 export issue, is it possible to kindly update it to still work as a APK to AAB converter? I find it to be really efficient, because I like to manually edit APK before publishing and then need the conversion tool

Unfortunately, I haven’t found the time to develop Vulpecula. I’m focusing more on expanding my portfolio.

There are plans to build something similar to Vulpecula, that will be open-source, but it’s not a priority for me at this time. I apologize.


No worries, good luck with your portfolio