Android 10 (API 29) Installation on Google Play

i just uploaded to playstore my app with sdk minimum requirements as Androi 10 (API 29)
but when i am trying just Android 10 minimum can installed it

in google page mentioned :
https://developer.android.com/distribute/best-practices/develop/target-sdk#why-target
“Configuring your app to target a recent API level ensures that users can benefit from these improvements, while still allowing it to run on older Android versions.”

i found one app uploaded in december 2020 and i think it used same sdk minimum requirements but i can install on bluestack emulator but my app doesnt

is there any way how to do that
so my app can install with lower sdk ?

You can set minimum api to 21…
Or probably I don’t understand your problem :thinking:

can you upload to playstore with api 21 right now?

" When you upload an APK, it needs to meet Google Play’s target API level requirements. New apps and app updates (except Wear OS) must target Android 10 (API level 29) or higher."
https://developer.android.com/distribute/best-practices/develop/target-sdk

I mentioned minimum…
Sorry but I haven’t uploaded or update any app recently…
Let me try one and respond to you…
BTW Kodular app already target API level 29

i am waiting

1 Like

guys i am sorry for my bad english so many of you didnt understand what did i want

kodular can export apps with api 29 for minimum requirements upload to google playstore
i have published my app

my question is
is there any step or strategy that my app can be install with phone lower sdk/api

for example my phone is samsung with newest os on api 29 can installed my app
my other phone is xiaomi with api 25 couldnt installed my app

so many of my target/audience couldnt install my app, right?
is there any configuration or something else should i do so my xiaomi with api 25 could install my app from kodular published with api 29?

because in google says
"“Configuring your app to target a recent API level ensures that users can benefit from these improvements, while still allowing it to run on older Android versions.”

May be this reply by @Vishwas on other topic clears out your query/confusion

The default settings on Kodular (as already posted):

targetSdkVersion=29minSdkVersion=19

Is there anything unclear with that? I do not think so.
So just leave it at that.

grafik

thanks now its clear obviously
many thank guys

So close this thread by clicking on Solution.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.