APK generates, but app doesn't work

It seems that, even a bit slowly, build system is working.

But it seems the generated APK results in a non working app. Anyone else experiencing this?

I can generate the APK, install it on a real device, but the app just shows splashscreen for half a second then quits.

1 Like

Also, Windows Defender detects generated APK as having a treat: Trojan:Win32/Wacatac.B!ml

Uploaded the file to virustotal.com and the site returned false to every check. Still, it’s strange, if anyone else had this it would be nice to know.

Is it just me having this issue with gen. app not working?

Sorry can’t confirm as I have not been able to build any APK yet

2 Likes

there is an error in the user login in me

Using Firebase Auth?

What causes the most anguish is that after several discussion threads, we have still not received any response from Kodular administrators.

3 Likes

why kodular not fix it

yes, I use it, but it doesn’t work, I can’t get the apk

I can generate an APK today, but there is something seriously wrong with the system and every single APK now has screen height issues. Auto height sizing for components like cards is not working correctly and I’m losing components/cards off the bottom of the screen or they’re clipping. I also have an extension (GetMetrics) that calculates the screen height and displays a FAB if it’s under a certain height. The FAB is displaying all of the time, even on large smartphone screens and tablets. It all worked perfectly until around maybe three or four days ago. I haven’t changed anything in the AIA files, other than some completely unrelated tweaking to unrelated number crunching procedures. If I now load up saved AIA files from a month ago, files I know worked 100% perfectly, they are all showing the same errors and not displaying heights correctly. All of these issues seem to have begun when the system was struggling to generate APKs (and I’ve also found it won’t save anything either, you have to ‘save as…’ for everything now).

1 Like

Looking at the dates, it seems that all my issues, plus the apk issues, seem to have occurred following the recent update of kodular to Version 1.5C.0.

1 Like

Things are definitely wrong, specially with communication from the devs. I guess it wouldn’t hurt just to acknowledge and say “we’re working on it”.

Hope someone from the team can step up and say something. But I guess we had it comming when we signed for a free service.

1 Like

I paid for this service with a premium account, specifically because I thought it might provide a better service.

Right now, I cannot do any app development as the layouts are screwed in my apps and I can’t build anything new in an environment that’s not working correctly, not least as I may have to change them again when (if) it’s fixed.

I had wondered if it was an extension issue, but it’s definitely not as it’s happening with kodular components as well. In my case, with the broken layouts heights (and widths too, I’ve just discovered) the update must have broken how the screen sizes are identified or how the app responds to them etc.

I’m now left with every single backup I have of the app - about 80 different aia files - stretching all the way back through its development, not working correctly. That’s a pretty big bug in the update and surely I cannot be the only person seeing layout errors and glitches since the update?

2 Likes

You face this problem when installing the application it does not work on these components

It looks exactly like what is hapening to me.

Have you had any luck after removing any of the extensions?

This isn’t just you, I and everyone here are also experiencing this… maybe it’s being fixed by Kodular.

2 Likes

14 posts were split to a new topic: 206 screens, app not working

You could use logcat to find out more

Taifun

Thank you for writing this howto, I didn’t know that.

I have the same problem, the app runs only when I remove the firebase authenticaition component