App not compile - Build Failed

Here is a aia file, even now i have remove everything from app, still its show this errors.
demo.aia (1.9 MB)

You have one project in a project in your aia file, that’s why


Mean, I am understand.

Have you done something with your aia file outside Kodular, manipulated it or so


no brother nothing, before i am not facing such issue. The app is already in play store.

No way, Boban is correct (as always):


I don’t know what happened, But how i can fix it now?

Here you go contact_demo.aia (1.7 MB)


1 Like

I faced the same problem too. Before this, i can export and build my application. Then i want to build again, it was failed. I DONT KNOW WHY PLEASE HELP ME GUYS

After i uncheck [Show Lists As Json] and delete packege name in Advanced properties - Can export APK file.

@ Boban I also have similar problem with my app. I had changed few parameters of global variables in screen and tried to export as apk. Since then I’m unable to get the output. I tried undoing the changes I made and still it didnt work. Then saved the aia file to my computer and deleted all the blocks of that screen. Still the error exists. I tried altering many blocks, but nothing is working out.

Could you help me solve this, if you are willing? And also can you tell me how you explore the aia file in computer?

I’m using 7-zip to explore the aia file, if you see assets, src and youngandroidproject after external_comps folder in your aia then you have project in a project, see the image in post 12

Just delete those and reupload your aia to creator…

If you are still not able to fix it by your self, PM me your aia and I will do it for you…


Thankyou for your quick response. Will check it out and comment. :v:

Make sure to make a copy of your aia as backup before you start deleting stuff.

Thankyou @Boban …!!

It worked!! I had downloaded more than 1 copy at the time of my crisis. Anyway, I had a project in my project and deleting those files solved the problem. Thanks again man :star_struck: :star_struck:
One more thing, could you explain the reason for this happening (project in a project)?

You imported a project as an extension.

1 Like

i am facing the same problem . I am attaching my aia file , please go through it . I will be very thankful to you.DesiGamer (1).aia (959.3 KB)

This should work
DesiGamer.aia (939.9 KB)

1 Like

Thank you i solved my problem